App styles files do not get compiled


#1

Hey,

My name is Aditya and I wanted to contribute to Code Combat as part of GSoc '14. I started off by downloading the source code to my machine and installing all the dependencies and running the scripts as mentioned in the wiki. Everything worked fine, but when I tried to load the page, it gets loaded without any styling. I tried to check what went wrong and found that none of the SASS files in app/styles have been compiled. Only the vendor/styles get compiled and thus the page loads without any styling.(except for some of the styles provided by vendor/styles files)

I tried changing the regular expression to try and compile only the app/styles folder. In that case, nothing at all gets compiled and I don’t even have a public/stylesheets folder.

I’m not sure where I’m going wrong here or if its a bug. Any help would be appreciated.

Thanks!

Aditya


#2

Hey,

Turns out there was some issue in the sass-brunch and other node modules due to some network issue at my college. Re-installed through another network and everything seems fine now.

Sorry for the trouble.


#3

Hi Aditya! Glad you got that figured out–network issues installing packages, oh my. Sounds like no fun. Let me know if you run into any other issues; would love to help get you set up and cracking on the project.


#4

Haha that’s true! Thanks a lot but its working great now. I’ve tried resolving one of the easier issues, let me know if thats fine or if I should make some more changes. Really excited to further contribute to this project! :smile:


#5

Awesome! @schmatz will check out that pull request when he gets a bit of time (his girlfriend is visiting this week)–it looks pretty good! Swing by our HipChat some time (when we’re awake) and we can talk more about what you want to do.


#6

Cool! I’ve PM’d you regarding this :slight_smile: