Cannot register a free account


#1

Hi,
I tried to create an account for my daughter, but I cannot pass the birthdate form : I enter all 3 fields (whatever the values), but keep having a “required” error.

Thank you !


#2

Hello,
What browser are you using? Can you please share a screenshot of the error?
Thanks.


#3

Hi, im having the same problem at the moment, I cant register as a free user, there is a bug on the birthdate page when I’m about to sign in… ( Tried with firefox and ie aswell )


#4

Hi,
Same problem here: I entered my birthdate and I can’t go to the next step.
Here’s a screenshot from Firefox.
I


#5

Hello UltCombo,

Thanks for your reply.
I used the latest Firefox version with Windows 10.
I just tried with FF47 on Ubuntu 14.04 LTS and I have the same issue.

I just tried with Chrome on the same Ubuntu, and it passes without the error.
The displayed error is the same as Iron_Momo


#6

Should be fixed now in Firefox–thanks for the bug report!


#7

Thank you for your action Nick.
I reloaded the page (ctrl-F5), but the error still occurs.
Should I do something else ?


#8

I just retried and it works, thank you !