Can't target the skeletons in Restless Dead


#1

I’ve tried to select them with
enemies = self.FindEnemies()
enemies = self.findNearest(self.findEnemies())
enemies = self.findByType(“skeleton”)
enemies = self.findByType(“decaying skeleton”)

etc. and on, but i always get back nothing. can’t seem to target anything to cast spells on or command soldiers to attack.

I’ve been running this loop to make sure that something is actually happening in my code and no matter how i define enemies it just keeps looping and confirming that it is checking. It finds the Yeti Cub. Just not the skeletons.

loopCount = 1
loop:
    self.say("loop #" + loopCount)
    enemies = self.findEnemies()
    if len(enemies) > 0:
        for enemy in enemies:
            self.say("enemy is " + enemy)
        self.say("there were enemies, breaking")
        break
    loopCount += 1

#2

Bump. How do I get the skeletons into an array? What are they called in the game? How can I target them to order an attack on them? Am I doing this level wrong by thinking I’m supposed to attack the skeletons in the first place?


#3

This must have been a glitch. Today my code picked up the skeletons with no changes and instead of showing some mysterious stuff about hero targeting something by the red crosshair in an enemy’s details when you click on him, it now shows a skeleton’s name.


#4

Hmm, that’s weird. What glasses were you wearing? I wonder if they were obstructed by obstacles so you didn’t have line of sight to them?


#5

I was using Enchanted Lenses. I had tried putting myself right in the cemetery where they come in as well.


#6

Try using self.findNearestEnemy()


#7

This topic, frankly, has died long ago. I’m sure after two months, he’s solved the problem. Leave the dead post resting.