Copper Meadows default Clojure code contains <%= blah %>


#1

It also makes me “comment out the (default) code” because of slow code or infinite loop. I guess that is the “dotimes” which “donothing”. (Drop The Flag, also has the <%= blah %> in the default code)

return  ;Commented out to stop infinite loop.
;; <%= c1 %>
;; <%= c2 %>
;; <%= c3 %>

;; <%= submit %>
(dotimes [n 10000]
    (let [flag (.findFlag this)]
        (if flag (do
            ;; <%= pick_up %>
            
        ) (do
            ;; <%= move %>
            (let [item (.findNearestItem this)]
                (if item (do
                    (.moveXY this (.x (.pos item)) (.y (.pos item)))
                ) (do
                    (.say this "<%= place_a_flag %>")
                )))))))

I can guess the general idea for what “submit”, “pick_up”, “move”, and “place_a_flag” are probably replaced with but for “c1”, “c2”, and “c3” I haven’t a clue.

I just switched to Javascript and reloaded, fancy comments worked fine, switched back to Clojure and reloaded, no dice.


#2

While I cannot help you with your problem directly (I don’t know what causes this), I can at least give you the comment-replacements:


Can you please add an issue about this on GitHub? This way the bug will be tracked and faster solved by the developer team.


#3

Not sure why it isn’t translating those interpolation strings; it looks like the formatting is correct. Maybe because of the infinite loop at first? I’ve reduced it to 1000; maybe that’ll work better. Do you still see the placeholder strings if you hit Reload to get the original code?


#4

I just fired it up, switched from python to clojure, reloaded and got the bad <%= %> stuff. (since I went in with python code there was no slow/inf-loop thing.)

(looks like he says that he tried “reload” at the end of his post.)


#5

Okay, now I found it. There was an extra <%= submit %> tag that was hosing Clojure.