Adventure Email level - Cavern Survival


#1

I can’t seem to load this level. Is it the same cavern survival already on the map? a new one?

this is the javascript error I get (windows 8 machine)

The usual stuff

Populated defaults for User Vlevo in 14ms
app.js:407 lib
vendor/aether-clojure
vendor/aether-coffeescript
vendor/aether-io
vendor/aether-javascript
vendor/aether-lua
vendor/aether-python
vendor/coffeescript
vendor/d3
vendor/difflib
vendor/diffview
vendor/three
vendor/treema
views/account/AccountSettingsView
views/common/SearchView
views/editor
views/modal/ModelModal
views/modal/RevertModal
views/play
app.js:407 loaded 19 files, 1429 KB
app.js:96 Populated defaults for Level Cavern Survival in 299ms
v3:1 Mixed Content: The page at ‘https://checkout.stripe.com/v3’ was loaded over HTTPS, but requested an insecure image ‘http://codecombat.com/images/pages/base/logo_square_250.png’. This content should also be served over HTTPS.

(program):1337 Hero Placeholder could not find ThangType for 529ec584c423d4e83b000014
(program):1337 Hero Placeholder 1 could not find ThangType for 529ec584c423d4e83b000014
(program):1 Uncaught TypeError: Cannot set property ‘stateChanged’ of undefined
(program):6 |Eos’s Archer| Worker initialized after 4058ms
(program):6 |Eos’s Lana| Worker initialized after 4385ms


#2

Same problem here. It occures while opening this level via the link in email.
Here is console log:

 Hero Placeholder could not find ThangType for 529ffbf1cf1818f2be000001(program):1337 module.exports.World.loadThangFromLevel
(program):1337 Hero Placeholder 1 could not find ThangType for 529ffbf1cf1818f2be000001(program):1337 module.exports.World.loadThangFromLevel
(program):1 Uncaught TypeError: Cannot set property 'stateChanged' of undefined
(program):6 |Set's Pam| Worker initialized after 2805ms
(program):6 |Set's Woodhouse| Worker initialized after 2807ms```

#3

While not technically in this level, I sometimes as well have that problem.

Usually, after a reload the ThangType can be found, so I suppose it has something to do with the ThangType not transmitted correctly/a networkfailure inbetween.


#4

I’ve compared the URL’s of the Cavern Survival from the email and from the Dungeon map – they are the same.
Level loaded just fine from the Dungeon map and it didn’t from the email link, even if I strip all the URL params after the ‘?’ character.

Maybe it doesn’t reveal the source of the problem, but definetely, it doesn’t seem to be a new source of gems for us :wink:


#5

For me, it works like a charm. It reloads this level with my previous code and run ok. (JavaScript).


#6

Still having the same error on my Win8 box. I cleared cache, rebooted, and still same error. (ripping the stuff off (?..) and htting enter doesn’t change anything, but ripping it off to “/play” and hitting enter and going in through the dungeon works fine. THEN the link from the email works.)

Linux box is happy, and goes to it just fine.


If it is the old one are you claiming that CC is not doing 5 new levels like the email says??? (I don’t know who to “Tsk, tsk” more you for suggesting it or them for making us think it.) :wink:

(There is a cavern survival 2 in the level editor so I was wondering…)


#7

The Cavern Survival 2 is a level by Catherine (the new Main-Artist) to test stuff without breaking the original level, at least as far as I’m informed. They currently should look pretty much the same.


#8

Ah, cool.

That still leaves us with the “tsk, tsk”…


#9

We had never formally released Cavern Survival, it having been in a sort of open adventurer beta state for a long time, so we took the time this week to polish it up and make a bunch of changes to get it ready to take out of adventurer mode, like we did with Dueling Grounds a few weeks back. Now all four hero multiplayer arenas have been released.

I have this bug on my list to fix, but I haven’t been able to track it down yet. The debugging details here are helpful, thanks!


#10

I’ve found another bug/exploit:
I was able to replay with the builder’s hammer because I went straight to the level, where I already had it equipped. Not that I mind being #1 for a while, but I think I found this behavior on one other level as well. When going to a level from a link or by inputting the url directly, if you cancel out of the equip screen you can start the level with whatever equipment you used for the last level.
(not sure if this link will work, but here it is anyway: http://codecombat.com/play/level/cavern-survival?team=humans&opponent=548a78af971a8d4b073144d2)


Has anyone beaten "The Trials" on a free account?
#11

Thanks for the heads up; I’ll fix that bug. I completed the nerf for the fences (they get banished immediately now).