[Adventurer] Medic School


#1

Mountain level Medic School is ready for testing.

It’s the mastery level in the series about startsWith function.


#2

I completed the level just fine, but why does the pet say “I don’t think that is an item, or a container”?

On a side note, I feel bad for Anya because she has to eat poisonous mushrooms to complete her missions! :see_no_evil:


#3

I suppose you tried to make the pet collect mushrooms? They can be carryable, but not in this level.

They are heroes, they are ready for sacrifice for science!


#4

Actually, I didn’t change anything below the startsWith function (the onHear function and the while loop), so Anya’s the one who collects mushrooms. The pet just brings the replenishing potion to Anya, and when she drinks it the pet says that (I thought the pet isn’t supposed to say anything).


#5

Maybe some collisions, when a pet tried to get the potion which was dropped, but already collected by the hero.


#6

The thing where the pet says “I don’t think that is an item” should be fixed now.


#7

I still have it (I use Chrome v.54 if that matters?).


#8

Try clearing your browser cache and see if that helps?


#9

I happily noticed that the python interpreter now understands slicing!


#10

Completed the level without issue

added LUA patch