Aether : can't grunt build from master


#1

Hi.

I’ve just cloned the repository and typed npm install then grunt build.

An error occurred :

Running “browserify:src” (browserify) task
SyntaxError: Line 1481: Unexpected string while parsing /mypath/aether/node_modules/escodegen/escodegen.js
Warning: Error running grunt-browserify. Use --force to continue.

I don’t really know whether you are already aware of that.

Regards.


#2

I can’t say for sure, but I just did some huge Aether updates, including updating the escodegen version (which seemed to be very old). Would you mind trying again and letting me know how it goes? I’d love to get this solved, just haven’t seen it myself.


#3

I always have the same error.


#4

git pull, npm update, and give grunt build another try. I just updated the browserify version, so hopefully it’ll be fixed. Please let me know!


#5

It works right now. Thanks.


#6

Funny, I just saw the same issue again and it appeared to be a bug with browserify, so I ended up having to fork two modules just to require an older version of browserify so that it could build again without this error.