Bug on level "True Name"


#1

Getting a bug on the level: “True Name”

Infinite Loop Detected
The initial code to build the world never finished running. It’s probably either really slow or has an infinite loop. Or there might be a bug. You can either try running this code again or reset the code to the default state. If that doesn’t fix it, please let us know.

Any advice? Tried the above and no luck.


#2

If you open the dev console, does it show any code errors?


#3

|Enlil’s Ray| Non-UserCodeError: ReferenceError: event is not defined
ReferenceError: event is not defined
at new t (https://codecombat.com/javascripts/world.js:410:178)
at World.module.exports.World.publishNote (https://codecombat.com/javascripts/world.js:326:112)
at t.e.exports.t.publishNote (https://codecombat.com/javascripts/world.js:204:80)
at t.Attackable.die (eval at (https://codecombat.com/javascripts/world.js:323:20), :71:10)
at Combat.update (eval at (https://codecombat.com/javascripts/world.js:323:20), :48:15)
at t.e.exports.t.getNextFrame (https://codecombat.com/javascripts/world.js:384:100)
at World.module.exports.World.getFrame (https://codecombat.com/javascripts/world.js:287:52)
at World.module.exports.World.loadFrames (https://codecombat.com/javascripts/world.js:296:10)
at https://codecombat.com/javascripts/world.js:293:172

That’s what I got, when I tried.


#4

Aha, one more change from the CoffeeScript compiler that I had missed. (Wonder how long I’ll keep finding these…) I’m deploying a new version now; should be ready in 20 minutes, after which another browser cache clear will help.

Sorry about that; thanks for tracking that one down!


#5

Thank you, also experiencing issue :smile:


#6

Sorry still not fixed here.


#7

The deploy just finished, so if you clear your cache, you should see it load now.


#8

Thanks Nick, cleared cache, and is now working on my end. -Firefox Browser.


#9

Thanks, I will let you know.


#10

Working now, thank you!