Deadly dungeon rescue - how do you get the bonus?


#1

Only the torturer killed and rescued the peasant, but I can’t get the bonus.

I tried to collect the chests (4) and coins (4) to get the level bonus, but that didn’t seem to be enough so I assumed the scattered equipment (6 swords, 2 helmets, have I missed some?) also counted as treasure and tried to collect all of those too, but I don’t see how?
There is a helmet in the upper mid part of the dungeon that always gets picked up by a guard. The same goes for a sword in the lower mid of the dungeon. If those two items are included in the treasure count, how do you get them?

Not sure if this is a level design bug or maybe I’m just missing something?


#2

The treasure is just the chests and coins in that one area.

I just ran it and you’re right, I didn’t get the bonus checked, but I have in the past, so something has changed…( @nick @Catsync )


#3

Thanks for the input, good to know! Now I can finally sleep… :slight_smile:


#4

from me the same :wink: i collect all and didnt get rewardet. In the past i did.
sleep well @avolo im goint too… :sleeping:


#5

If I recall right, @sotonin is checking for exact gold value. If you carry a Boss Star, you can not achieve the goal because you have 20 Gold upfront and an income of 0.5 gold per second.

Try to unequip the boss star.


EDIT It isn’t the boss star.


#6

Thank you all for taking the time to reply.
@JBFM: Sadly, I don’t know what a “boss star” is and quick googling it only gave a few incomprehensive answers so I’m
still at a loss here (maybe google isn’t my best friend, after all?).

All I can gather from JFBM’s answer is that I have something equipped that makes an x value item worth x+n which breaks an exact value comparison since 8x doesn’t equal 8(x+n) unless n is zero.

I don’t know the mechanics of the engine, but it seems that:

if (collectedchests + collectedcoins)==8 then “gimme the bonus I need really bad to beat the trials since I did some unawaring spending before and have run out of non-subscriber levels”

would do the trick?


#7

Upps, I saw Vlevo’s answer and I know how far he is.

The boss star is an item you only get after a certain level in the mountain area. If you are not there yet, my answer doesn’t apply to you.

I’m sorry. The item is relatively new, so Google might not know it (in the context of CodeCombat).

For future reference, please include whether you have the boss star equipped or not.


EDIT
After replaying the level I also didn’t get the bonus, but I apparently completed it in the past once. This was when I unequipped the Gold-Giving item.


#8

Well i’m not sure what is causing his specific issue. but I fixed the boss star problem by checking >= instead of just the exact gold amount.


#9

@sotonin: Just ran it again and your “>=” did the trick. Thanks!


#10

The flag thingy for “Deadly Dungeon Rescue” on the “Dungeon” map is still gray though, despite beating the level and refreshing the browser page. Is that as expected, haven’t seen that before?


#11

Try resubmitting the level


#12

I tried “login, resubmit, logout” several times in both Firefox and Chrome and refreshing the page, but still a gray flag.


#13

I think you have somehow gotten a second session started for that level. I’ve seen this twice before, but haven’t been able to track down the cause yet. Do you remember anything strange about how you started the level, or anything thereafter, that might have caused a second session to get created?


#14

I have been logged in from both Firefox and Chrome at the same time to compare performance and response times, maybe that’s the origin of the problem? Or do you mean two sessions in the same browser?
But I also have been logged in separately in both browsers at different times and resubmitted and the flag remains gray as if somehow my stats isn’t updated.

I assume the user stats is saved at one single point before the “Success!”-window is displayed? And also that there is some conditional code that decides whether to save or not?

I don’t have a clue to how the server code is designed so I don’t understand why multiple sessions could cause the problem. If you have a moment to elaborate a little on your theory I would appreciate it and also if you have any suggestions to any relevant code to debug on the client-side.


#15

Yeah, that was it. I don’t know how it happened, but there was a second session created, and the campaign view was only fetching that second session (which was incomplete) even though you had a first session which had beaten it, which is why the flag hadn’t shown red. I have deleted that extra session now.


#16

Thanks for clearing that up, it looks a lot better now with a bright, shiny, red flag.