Error when loading level locally


#1

I forked the code a while back and just recently set up my machine to run it. When I try to load the rescue mission level (http://localhost:3000/play/level/rescue-mission) I see the loading screen with a full progress bar but then it just stays there. I’m using chrome, and this is what’s printed out in the console:

Uncaught TypeError: Object # has no method ‘call’ underscore.js:159 (anonymous function)underscore.js:159
.some..anyunderscore.js:208
.find..detectunderscore.js:158

CocoModel.getReferencedModelCocoModel.coffee:152
CocoModel.getReferencedModelsCocoModel.coffee:146
module.exports.Level.getReferencedModelsLevel.coffee:110
CocoModel.getReferencedModelsCocoModel.coffee:144
module.exports.Level.getReferencedModelsLevel.coffee:110
SuperModel.modelLoadedSuperModel.coffee:27
(anonymous function)SuperModel.coffee:1
triggerEventsbackbone.js:209
Backbone.Events.triggerbackbone.js:148
options.successbackbone.js:437
firejquery.js:2913
self.fireWithjquery.js:3025
donejquery.js:7400
(anonymous function)jquery.js:7822

Uncaught TypeError: Object function (obj) {
if (obj instanceof _) return obj;
if (!(this instanceof _)) return new _(obj);
this._wrapped = obj;
} has no method ‘cloneDeep’ Level.coffee:11

module.exports.Level.serializeLevel.coffee:11
module.exports.LevelLoader.initWorldLevelLoader.coffee:123
module.exports.LevelLoader.notifyProgressLevelLoader.coffee:207
module.exports.LevelLoader.updateLevelLoader.coffee:95
(anonymous function)

I set everything up using Steve Malmskog’s instructions, and it looks like everything worked (I get the home page for the site atleast, and can see the levels listed when I navigate to the Levels section). When I try to load the level the mongo and dev-server terminals don’t seem to indicate any errors.

Any thoughts? In the meantime I’ll update the code in my fork and maybe run through the install process again just to be sure I didn’t miss anything.


#2

Do you happen to have some browser plugin that might be interfering with it? It sounds like it’s pulling in Underscore instead of Lodash, or some really old Lodash version.

Also, a bower install or bower update might help if you haven’t done that already.


#3

That was it! :smiley:

I ran bower install and tried the level again and it loaded all the way. I remember running into some problems with sass before. I must have re-installed sass but not retried the bower install. Thanks!