Hold the Forest Pass


#1

I can’t get past Hold the Forest Pass, no matter how many times I’ve tried. I would post my code here but I don’t know what I should even do at this point, I’ve tried so many variations and I just cannot survive! Please help…


#2

try not to use your sword, maybe the mines are better. Use the ambush, these Throwers are more than awesome. But u have to gess the koordinates. Or use nearest enemy… Electrocute helps to survive. Stay away from your horse and friendly troops while placing mines.


#3

On this level I had to get funky with bash, fire-traps and flags.

What I am implying here is that this level is randomized, soooooooo you have either to use really flexible code of flags(like really really flexible code) and using flags is easier


#4

I usually do it by moving between the archer squad and the left tunnel with flags, luring as many ogres as I can down to the archers to get killed. I’ll also cleave any groups of throwers (by just cleaving whenever I can and moving towards throwers with flags when it’s about to be ready.)


#5

like I said getting funky with flags


#6

is how you put the bomb in anywhere by this.buildTypes[“fire-trap”]? Please let me know thanks

also I have tried this this.buildXY(“fire-trap”, this.pickUpFlag(bomb), this.pickUpFlag(bomb); and it does not working…


#7

it is “.buildXY” so you give it x & y coordinates…

this.buildXY("fire-trap", 50,50)

Flags have positions (.pos which have .x and .y) so, if you place a flag where you want a fire-trap, and your code assigns that place to “flag”, looks like you called it bomb (so I am assuming you have some “bomb = findFlag” code (properly written for your programming language of course)) then you’d:

x = bomb.pos.x
y = bomb.pos.y
this.buildXY("fire-trap", x, y);

// or simply

this.buildXY("fire-trap", bomb.pos.x, bomb.pos.y);

#8

ah it does work thanks!


#9

I cant find out the cords in this level the mouse isnt showing can someone tell me the cords for the fire traps


#10

That is because you aren’t supposed to hard code locations on this level, but use flags to tell your hero where to go…


#11

oh ok thanks for the help


#12

i still can’t do it it say that the parentheses doen’t match I need help PLz.


#13

Hello, Hyeong, and welcome.

Phrases like “I need help!” or “This code doesn’t work!” do not help us help you. Please give us more information. Your code, formatted properly, as per the FAQ. A screenshot perhaps. A description of your error.


#14

Can you just copy and paste it to me?


#15

Help plesessssssssssssssssssss
i cant figure it out


#16

We’ve made it a policy not just hand out code wily-nilly. After all, the point of this is to learn, which you can’t do with Copy/Paste. (MC FTW)


#17

Also please post your code, but format it according to the FAQ


#18

My hero doesn’t seem to be able to move using the flags. He just stands there with the archers. What do I do to fix it?


#19

Post your code. Format it by surrounding it with 3 backquotes

code


#20

As @AdrianCgw mentioned, please post your code with radiant and harmonious formatting, as described in the FAQ. Phrases like ''i need help" or “i can’t figure it out” don’t help us help you. Please post your code (with formatting according to the FAQ) , what happens, and anything else that would be helpful.

Cheers! @Luke10