Level Editor How What Where?


#1

Helloes ! I was wondering how do we use that Editor to it’s maximum capacity? I have tried to play a tiny bit with it, but it seems i cannot remove a Thang once i added it. Help?


#2

Hi nightwolf! It’s pretty rough right now, but really appreciate you testing it out. Right now we’re focused mostly on trying to get the site more stable, but we’ll try and give you and other editors a hand learning the ropes.

Check out this super crude doc I threw together with the most important info. Feel free to comment on it so I can improve it:

Regarding deleting units, select one on the ‘thangs’ tab either on the map or on the list on the left and press ‘backspace’, or ‘delete’ on your mac keyboard.


#3

Thank you very much. I will start fiddling with it. I will keep you updated. Also, if i have time, i will try to learn the programming language you guys use, and apply for dev position so i can help out at programming too :slight_smile: . Have a nice day.


#4

Cool! This site can get you started on learning the almighty CoffeeScript:


#5

I has an issue. I made the Night Attack level from scratch, and aparently, when i play it, it says Level Complete. What did i not do?


#6

There’s currently a hack in place where the level is considered complete if no ogres remain alive. We’ll be changing that soon (not sure how, Nick and I need to talk about it). I had the same issue so I figured out a (super temporary) solution: have an ogre off screen and not participating in the level. As long as the other units don’t see or interact with that ogre, it shouldn’t break things.

Stay tuned for a non-hack solution.


#7

I added an ogre. And basically Tharin needs to cut a tree to get to that ogre. And here comes the problems.
I made the tree attackable and of team ogres. First time it rulled ok. When the tree “dies” it rotates upside down. and you can pass through. But, at second and third playing of the level , half the timeline it is stuck ? o_O . Frozen.

Earlier, When i added the Attackable component, the tree dissapeared. I could not click it in the thang list, nor could i see it. had to reset to previous save.


#8

Hah, I did the same thing last week to see what would happen, making the tree attackable. Don’t really know why it does that fall over thing, but you should probably avoid using units like that until we add death animations to them. Seems like we have something else to have our artist do.

It sounds like you’re describing with the timeline is how it behaves right now, where the timeline goes until there are no more living ogres, plus a few extra frames. We’re going to change that soon so that the timeline ends when all goals are complete plus a few extra frames.

If you get the level into a crazy state, save it and send it our way and we’ll see if we can figure out what’s going on exactly.


#9

Hey there, I’ve been working with the editor and ran into a couple of bugs.

  1. If you rename your level to something too long and then save it, it seems to disappear completely, both the version with the old name and one with a new name is never made.

  2. For some reason when removing “combat: AttacksNearby” from the starting soldier’s Components, he disappears when you save/reload the editor. You can see him listed and can double click to edit the Thang properties, but you can’t select him to delete. Additonally, when you go to play the level, it freezes on Building World. This also pretty much requires restarting the level design.

For an example of the second, try loading up http://codecombat.com/editor/level/the-least-resistance

Thanks, have been enjoying learning the editor thus far!

Edit: Also just remembered something. When playing Commanding Followers, the camera zooms in at the start of the level, but never zooms back out. If you go into the “Soldier Selected” script and add “Script: Duration=5000” to the “Hide the Highlight” action and then add a secondary action of Surface->Focus->“Focus: Zoom=1, Target=”, it’ll pretty naturally unzoom after you click your soldier, while still being able to see the responses of your followers.

I remember the level being kind of a guessing game for coordinates since it was so zoomed in.


#10

Adding these bugs to the list of things to fix, yeah these look nasty, thanks for your patience on having to recreate some work.

I like the suggestion, added that to Commanding Followers. I think we’ll be retiring Commanding Followers, actually, or at least changing it quite a bit. Too much reliance on string ‘magic’, whereas the natural coding solution would be to use things like method calls to command followers to do something. The zoom system in general is also slated for fixing.


#11

This level editor seems very promising. However, I cannot put any units on the background? Is there a setting for it or is it just a bug?


#12

We have a bit of work to do! Try putting down a Land (either “Dungeon Floor” or “Grass”) first, and then putting units on top of that.


#13

Thanks! Now it works :slight_smile:


#14

How do you configure components for each thang? There are no drop-down menus for the components already there and I cannot seem to add other components.


#15

I was able to double click the name of the thang on the left to bring up the configuration.


#16

I did that, but then when I click the component it just brings up a blank white screen.


#17

Just curious, which Thang (or Thangs) were you trying this on? Once you double click on the Thang from the main screen and it shows components in the left column and add components in the right I’ve seen some that don’t have any options (like ai.chasesAndAttacks). Do they all show up as not having options for you? I also found it odd to add components, I had to click on the very right hand side in my browser and hit enter to add them. To remove them I had to select them on the left and use my backspace button. Some just showed up as a + button and I went to other examples and copied the expected properties and stuff from them. Another thing I’ve tried in such situations is just to use a different browser and make sure it isn’t that kind of bug.


#18

A lot of the Components don’t have any configuration properties, as you say. And yeah, selecting the Component, hitting enter, and then going over to the left side to select it again is probably among the worst pieces of UX on the site right now! Sorry about that.