Level - The Geometry of Flowers


#1

I can’t click on play.
The level runs but I cannot change equipment. Play button is gray.
Does it equip in a wrong place or something?


#2

The same for me.
It seems that the required object (ring of flowers) is not correctly assigned or there is a requirement mismatch.

The same happens for the “Mountain Flower Grove” level.


#3

That problem is already known and trying to be dealt with. Sadly the developers need sleep too (despite certain rumors about robots being part of the core-team). That is what Adventurers have to deal with, non-working or absurdly unbalanced levels.

Thanks for reporting the bug, I’m sure it will be solved soon.


#4

I think we have removed the restriction on this one for now, since it’s buggy. If you still see the restriction somewhere, you can try dragging the ring to the other slot–might work?


#5

I don’t know about others but for me it is still broken. Caching no caching, play button is still gray, same problem. Dragging does not help.


#6

The same for me, still not working.
The restriction is present and it is not possible to drag the ring in the other slot.


#7

I’ve looked around but I can’t even figure out where to get the ring itself. I checked the shop and it’s not mentioned in the item ref either.

Edit: Thanks, @steog88 I didn’t know that level existed and I didn’t see it mentioned elsewhere.
I passed the level and got the ring.


#8

You win the ring as a prize in “The two flowers” level.


#9

I’m a bit behind with adding it. As it is brand new I didn’t managed to do it by now, but you can expect a complete verification of the whole list in the next few days.
I just have my head full of other things right now (like the Google Code Jam, which I prepare for since 3 days).


#11

Great, it is playable now. So cool that I can draw now.

It’s still not functioning properly though.


#12

Those don’t look like they are size 10. (Well, the square maybe, but the circle definitely isn’t)


#13

Well, maybe, but how am I supposed to measure it? Giving it some thought you might be right. Whatever number I put in size it gives me the same circle. I’ll try to fix it.


#14

oh, I see. you have the old circle code.

Copy all the code YOU did. then reload the level, to get the new default circle code.

Then it should work.


#15

It does, thanks. Yay, Boss Star II :slight_smile:


#17

I’m still having an issue getting into this level. When picking equipment it looks like the screenshot above, i.e. nothing in the slot 2nd in from the left - although it is in green; and the play button grayed out.

However I went into the html and enabled the play button, and it seemed happy enough (I completed the level). Although I don’t think I was getting intellisense for the flower commands (I can double check if that would help).

Could I have missed an item from a previous level?


#18

Do you have the “Ring of Flowers” from the previous level “The Two Flowers”?

I solved the bug you encountered simply playing a different level with the Ring: when i came back to this one the equipment was correctly loaded and the play button was available.


#19

Hmm, played another level an came back, I have the Ring of Folowers, but it almost seems like I need another ring to have all the required items?

I could buy one I guess - do you have two rings or one?


#20

Hmm, did the ring of flowers get equipped in the right slot but insist that it needed to be in the left slot still? What if you do localStorage.clear() in your JS console and then try again–any different?


#21

Yes it went into the right hand slot. I bought another ring (the Steel Ring), and when I equipped that the Play button became enabled. Clearing the storage, and removing the rings gave the same result.

It seems like the first ring selected goes in the right slot, and then the second goes in the left slot. The Play button becomes enabled when the left slot is filled, even if there is nothing in the right slot. Its also possible to add the Flower ring in the right slot, the Steel Ring in the left slot, and then remove the Flower ring - the play button stays enabled :slight_smile:


#22

I’m getting a message saying that I should be doing the cammand, this.toggleFlowers(false); when I’m doing that cammand. I’m not sure how to make it work.