Level: Winding Trail


#1

Winding Trail, it’s new it’s cool, and we would love to get your feedback about how fun/interesting it is. Bugs? Usability issues? Post 'em here.


#2

It may be just me but I couldn’t find this linked in from the main site? However I did guess a url:

And gave it a try, but couldn’t get too far - I think I kept hitting into the trees before the move was complete, so it looked like it was just stuck I think. Hope that helps?


#3

It should be available now: http://codecombat.com/play/forest

Can you share some code that wasn’t working?


#4

I have a feeling its all got a bit confused :smile: I see there is a forest set of levels now - although the Winding Trail still seems to be locked? Going through the URL it now seems to suggest that you use move(x,y), which would make sense, but those seem to be creating compilation errors, and only moveUp, moveDown etc are available. This is in Javascript, maybe different in other languages?


#5

If it’s locked, it probably didn’t register you beating Defense of Plainswood, which should give you the Leather Boots, which it wants you to equip. But ah, I see, there’s a bug in that, so it doesn’t tell you it wants them! I’ll upload that fix soon.

If you go through Plainswood again and see the victory screen show up, does it unlock Winding Trail for you?


#6

I have completed the Defense of Plainswood level and was given the leather boots, but when I start the Winding Trail level they are still locked. It doesn’t look like it’s possible to solve the level without having them unlocked and equipped…


#7

How about now? I’ve just pushed a fix to try to get them to equip more obviously.


#8

Ah, looks good now - took me a few moments to figure out I needed to build a fence, not just run for the exit, but its all unlocked and working.

I think its works better having the other two fence building levels before that in the forest - they always seemed a bit out of place at the end of the dungeon.


#9

All good now- thanks!


#10

Well this was a bit too easy !! Finished it in 1 line of code

this.buildXY(this.buildTypes[0],72,26);

:slight_smile: No Issues as such :sunny: Everything seems to be fine.A bit too easy perhaps ?


#11

But then you don’t get the bonus achievement for grabbing the gems! (Which I see we haven’t added yet.)


#12

I’m having 2 different problems with this level, (code is pasted below)

  1. walking over the gems does not collect them
  2. there is a black and white mark where i assume an X will go in the future
  3. I’m not sure where I have to stand for the system to believe that I got “to the end of the trail”

self.moveXY(34, 45)
self.moveXY(36, 60)
self.moveXY(34, 45)
self.moveXY(44, 22)
self.moveXY(37, 13)
self.moveXY(43, 19)
self.moveXY(65, 18)
self.buildXY(“fence”, 69, 20)
self.moveXY(73, 16)
self.buildXY(“fence”, 74, 20)
self.moveXY(81, 16)
self.buildXY(“fence”, 72, 16)


#13

I found this level a very enjoyable experience and that it was a test of my skills to look into the tools I had been given to discover how to get the hidden gems. I am unsure as to how you are supposed to complete it however without knowing about the fire trap, but it was a lot of fun having much more freedom in the movement of my character and being able to see the different ways victory could be achieved. If anyone is interested, here is my code

self.moveXY(34, 45)
self.moveXY(36, 59)
self.moveXY(37, 13)
self.moveXY(73, 19)
self.buildXY(“fire-trap”, 72, 25)
self.moveXY(65, 16)
self.moveXY(73, 61)

For malcolm and the issues you are having, it seems like your level is not loading correctly as in the version that I am using there is no white X mark on the map and the gems do collect in my version.


#14

@malcolm Wow, you hit this same bug twice. If you reload the level, you should see that getting to basically where you were, and building the fence to block the ogre, does the job.

I’m going to put an X there; that’s a good point.

The goal of the level isn’t really to get the extra gems behind the ogre; that’s just a bonus if you can come back later and defeat it. The single fence should suffice for basic completion. I’ll have to hook up the bonus achievements properly today.


#15

Much better today.

Did you add the documentation today? I don’t remember fire-trap being discoverable last night.

Also, I don’t know what it would take to put in a wait state, but I could use one in this instance, instead I had to wander around staying in the enemy sight, but out of blast range (I blew myself up the first time I used a fire-trap)

Sorry I missed one of you at the code-dojo last night, I found out about it this morning (the 6th of Nov)


#16

Good point about the waiting. wait will be a method on a watch you can acquire as soon as we finish importing the new item art.


#17

How do you get the bonus you’ve made the forest a safer place. Do you unlock it by killing the ogre because if so I already did but it won’t become unlocked. Please fix this or tell me what I am supposed to do to unlock this bonus. Here is my code.

self.moveXY(34, 45)
self.moveXY(36, 60)
self.moveXY(37, 13)
self.moveXY(72, 18)
self.buildXY(“fire-trap”, 71, 29)
self.buildXY(“fence”, 72, 18)
self.moveXY(73, 61)

I did the bonus where you collect all gems but I really want to finish the other bonus also. Thanks!


#18

@Enya Thanks for the heads up; looks like that achievement was misconfigured. I’ve fixed it and am recalculating it now, so you should get it in a few minutes.


#19

I am unable to unlock the level after winding trail. It tells me after my character sits at the end for 10 seconds that I completed it and I unlock the programiticon II. But when I go back to the map all it shows is that I completed the winding trail, but doesn’t give me an option for a new mission.

Here is my javascript code:

this.moveXY(36, 60);
this.moveXY(38, 14);
this.moveXY(71, 25);
this.buildXY(“fence”, 71, 25);
this.moveXY(80, 16);

Thanks!


#20

I checked today and the next level is unlocked, I hadn’t tried anything, it just unlocked after a day of not trying I guess.