Mighty Yak Problems


#1

Hey again,
I’m having weird error messages appear in clean (python) code that make me stand still and get run over by the yak. Can you guys inspect the error message code?
Thanks a lot!
I-code


#2

Post your codes first


#3

I’m not entirely sure the code will help because I tried moving like this:

self.moveXY(36, 54)

and it wouldn’t do anything, just put a red X under my hero and give me an occasional error message, like it did with the other code:

loop:
if self.distanceTo(self.findNearestEnemy()) < 10:        
    x = self.pos.x + 10
    y = self.pos.y
    self.moveXY(x, y)

Also, the error message that pulled up was “Unexpected Identifier”, without even giving the line number.


#4

In fact, I’ve tried some of the other sand levels and the same outcome happens with the moveXY statement.


#5

requip your boots


#6

I did that, as well as logging back in, but I now have worse problems: I can’t move onto the next stage! (sandlands)


#7

Try doing another level then try the sandlands level again


#8

Which account is this–not the Izard account?


#9

maybe change the name of the varabes


#10

As I said before, changing the names of the variables makes absolutely no difference.