Need help setting up dev environment

I tried the docker set-up and did exactly what the guide said, but when it was supposed to be running, it said my node version was 8.15.1, which is wrong even if I have node 14 (exactly 14, nothing but zeros after it in the version number), This is an issue since I wrote this topic, I tried starting issue and descussion on Github, but nobody answers. I don’t get errors at the moment, but here is a small bit of what the console said:

proxy_1 |
proxy_1 | audited 1233 packages in 7.255s
proxy_1 | found 57 vulnerabilities (5 low, 23 moderate, 28 high, 1 critical)
proxy_1 | run npm audit fix to fix them, or npm audit for details
proxy_1 |
proxy_1 | > codecombat@1.0.0 proxy /coco
proxy_1 | > COCO_PROXY=‘true’ nodemon
proxy_1 |
proxy_1 | [nodemon] 2.0.19
proxy_1 | [nodemon] reading config ./nodemon.json
proxy_1 | [nodemon] to restart at any time, enter rs
proxy_1 | [nodemon] or send SIGHUP to 28 to restart
proxy_1 | [nodemon] watching path(s): server_config.js app/schemas/**/* server app/assets/main.html
proxy_1 | [nodemon] watching extensions: js,coffee
proxy_1 | [nodemon] starting node index.js
proxy_1 | [nodemon] forking
proxy_1 | [nodemon] child pid: 40
proxy_1 | This requires Node v14. Your version: v8.15.1
proxy_1 | [nodemon] app crashed - waiting for file changes before starting…
proxy_1 | [nodemon] watching 180 files

git gud idk try contacting chaboi, hes usually good at this stuff, just remember he does live in tokyo so if u live in na (North America) it may be VERY hard to talk as he will most likely be asleep

Probably should do something about this

You need to update it

Okay, I went into the dockerfile (Under “development”) and changed the version to 14, and rebuilt. Actually my node version is 14.18.3. I ran “docker-compose up”, and I get the following:

proxy_1  | Using dev proxy server
proxy_1  | internal/fs/utils.js:332
proxy_1  |     throw err;
proxy_1  |     ^
proxy_1  |
proxy_1  | Error: ENOENT: no such file or directory, stat '/coco/public/images/favicon/favicon-coco/favicon.ico'
proxy_1  |     at Object.statSync (fs.js:1132:3)
proxy_1  |     at resolveSync (/coco/node_modules/serve-favicon/index.js:187:17)
proxy_1  |     at favicon (/coco/node_modules/serve-favicon/index.js:61:12)
proxy_1  |     at setupExpressMiddleware (/coco/
proxy_1  |     at Object.exports.setupMiddleware (/coco/
proxy_1  |     at module.exports.createAndConfigureApp (/coco/
proxy_1  |     at Object.module.exports.startServer (/coco/
proxy_1  |     at Object.<anonymous> (/coco/index.js:15:8)
proxy_1  |     at Module._compile (internal/modules/cjs/loader.js:1085:14)
proxy_1  |     at Object.Module._extensions..js (internal/modules/cjs/loader.js:1114:10)
proxy_1  |     at Module.load (internal/modules/cjs/loader.js:950:32)
proxy_1  |     at Function.Module._load (internal/modules/cjs/loader.js:790:12)
proxy_1  |     at Function.executeUserEntryPoint [as runMain] (internal/modules/run_main.js:75:12)
proxy_1  |     at internal/main/run_main_module.js:17:47
proxy_1  |  {
proxy_1  |   errno: -2,
proxy_1  |   syscall: 'stat',
proxy_1  |   code: 'ENOENT',
proxy_1  |   path: '/coco/public/images/favicon/favicon-coco/favicon.ico'
proxy_1  | }
proxy_1  | [nodemon] app crashed - waiting for file changes before starting...

in internal/main/run_main_module.js it’s trying to import an image that doesn’t exist (line 17)

I fixed that but now it gives me:

proxy_1  | Using dev proxy server
proxy_1  | Express SSL server listening on port 3000
proxy_1  | (node:54) UnhandledPromiseRejectionWarning: Error: ENOENT: no such file or directory, open '/coco/public/templates/static/home.html'
proxy_1  |
proxy_1  |
proxy_1  | (Use `node --trace-warnings ...` to show where the warning was created)
proxy_1  | (node:54) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). To terminate the node process on unhandled promise rejection, use the CLI flag `--unhandled-rejections=strict` (see (rejection id: 1)
proxy_1  | (node:54) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.

It’s trying to open an html file that doesn’t exist, but idk where, @Chaboi_3000?