Setting up Dev environment Windows


#1

Hi there,
I’m trying to set up dev environment on Win 7. I have installed all the prerequisite software as mentioned along with cloning the repository on my PC. Now trying to set up the dependencies but i’m getting the following error on
npm install -g bower.
Tried the configuration.exe but still the same problem. Here’s the log for it:

5409 error Error: UNKNOWN, open 'C:\Users\Current\AppData\Roaming\npm-cache\inherits\2.0.1\package\package.json’
5410 error If you need help, you may report this entire log,
5410 error including the npm and node versions, at:
5410 error http://github.com/npm/npm/issues
5411 error System Windows_NT 6.1.7601
5412 error command “c:\Program Files (x86)\nodejs\node.exe” “c:\Program Files (x86)\nodejs\node_modules\npm\bin\npm-cli.js” “install” “-g” "bower"
5413 error cwd e:\codeCombat\coco
5414 error node -v v0.10.28
5415 error npm -v 1.4.9
5416 error path C:\Users\Current\AppData\Roaming\npm-cache\inherits\2.0.1\package\package.json
5417 error code UNKNOWN
5418 error errno -1
5419 verbose exit [ -1, true ]

A little help please


#2

Hi peyuah! Are you trying the manual setup or using the automated installer from here? https://github.com/codecombat/codecombat/wiki/Setup-on-Windows:-a-step-by-step-guide

If you haven’t tried that second one, I’d recommend it–it takes care a lot of the dependencies for you. I’m not exactly sure what would be causing the error you’re seeing, but it does sound like some sort of problem with the npm install.


#3

Hey Nick,
Earlier I was trying manually but got tired of it. Tried the Automatic Installer and it ran successfully. I think the one error which i missed during manual installation that it was failing in npm install because of python version being 3.1 on my PC. Edited the code in configure.js and it ran smoothly.
One problem I am facing now that on running localhost:3000 i’m getting a blank brown page. I have disabled all my browser addons and firewall settings but still the blank page.
Any thoughts


#4

I found something similar when I was setting it up this morning. The problem with mine was brunch hadn’t installed it’s sass dependency properly and so failed to load when running scocode.bat - do you get all 3 command prompts up when you run it?


#5

Ya I’m getting all the 3 cmds up and running.
Tried updating bower and saas but still getting the blank page
There’s an error coming up, sorry forgot to mention earlier
error: { [Error: Component must have “E:\CodeCombat\coco\bower
_components\jquery\bower.json”] code: ‘NO_BOWER_JSON’ }


#6

@peyush try running a bower install again, then seeing if brunch compiles ~576 files, or if it’s significantly less than that?


#7

@nick Ran bower install and all dependencies were successfully installed. Only 546 files were compiling before. Had to open my port 9418 in firewall. I think that’s why some files were left before. Mighty thanks :smiley:


#8

I am also installing on Windows 7 64 Bit and am having install issues.

I was having the same issue with bower not being fully installed. I ran bower install and it resolved the issue with not finding bower_components, but now I am having a different issue.

When I run SCOCODE.bat the brunch window dies with the exception below:

The nodemon server and mongodb database windows seem to be working properly.

I have turned off my Windows Firewall to make sure that it was not blocking the port but did not have any luck.


#9

If you can swing by our HipChat room, I might be able to help you debug this. I think you might be having a sass-brunch problem.


#10

I am still having problems with the Windows install. I attempted to reinstall everything and made a little further progress but still have similar issues. I noticed that the when I ran the coco-dev/configuration.exe that the npm installation (after sass install) spat at a page of text, but I could not read it before it closed.

Is there a chance you could have a debug option that will keep command windows open after the task completes?


#11

The Windows installer needs some help, but I don’t have time to get my Windows on and update it, so I’m hoping someone on Windows can update the installer once they get it working.

It sounds like the thing to do would be to manually update node and npm to the latest versions by downloading it from the node site. You might also try a common Windows fix of removing the bless-brunch entry from package.json and deleting the bless-brunch folder from node_modules, then getting sass-brunch 1.7.0 with npm install --save-dev sass-brunch@1.7.0