Python Dictionary Issues this morning (Solved: Firefox specifc issue)


#1

Hello, so I’m having an issue with my python dictionaries this morning. Code I wrote that worked yesterday is no longer functioning. This include previously completed levels.

hero.command(friend, “move”, {“x”:30,“y”:50}) began throwing an exception “move’s argument pos.x should have type number but got function. Target an {x: number, y: number} position.”

i even tried to hero.move({“x”: 35,“y”: 35}) and received the same exception. Many of my previous levels now give it as well…

So my question is am I alone in this and how do I fix it?


#2

Hi, can you copy-paste your code and include a screenshot of the error you’re seeing? This is the second report I’ve heard of this, and are constantly tweaking performance for Python, so I suspect something might have been gobbled in a recent change.

Bonus points for web-browser, operating system.


#3
hero.move({"x": 35, "y": 35})

Linux Mint 17.3; Firefox 47.0

It worked great until today.