Self.attack("target") method unavailable


#1

I am unable to attack anymore, ie: the .attack method has become unavailable in my code.

I bought the builders hammer, and now this is the only primary weapon/tool that I am able to use.
There is no way that I can recover my old default sword. When I unequipp the hammer, the “PLAY” button becomes ghosted out.

Being that I dont have enough gems to buy a sword, and I cant advance forward because I cant attack, I am stuck. Catch 22. :bug: ? Or someone please direct me as to what Im doing wrong.


#2

Try to use “fire-trap” its kond of a mine. You can kill enemies with that


#4

I think that you could not attack them without your sword :smile:


#5

If you have lost an item you used to have try replaying the level where you received the item.

In this case that is “Forgetful Gemsmith”.

Pinned to the top of the list of posts is “When do I get which Item - A reference


#6

you have to select a sword. The items you wear matter.


#7

Thanks this worked. Redoing the “Forgetful” level, allowed me to be able to equip sword. Thanks.


#8

@captain_electro That is the issue…i can’t select a sword. @Vlevo solved the issue. Bug remains, but atleast i can continue on quest.