[Solved] The Big Guy Help(Bug reported by maka)


#1

I put this underneath bugs because the code is exactly the same as the course answer page. Whenever i try to beat the level, i get the error, “TypeError: game.setGameState is not a function.”

Here is all of the code, any information would be greatly appreciated.

do not post solutions

#2

try changing setGameState to setGoalState. You sure this is the answer given by Code Combat? (If it’s written by your teacher it might be a typo). Also did u hand-copy this or did u copy and paste it?


#3

It worked, i completed the level, but I’m am sure that my code was the same as Code Combat’s. Also, I hand-copied.


#4

@maka could this be a potential typo


#5

I’ve very confused by this thread. Why does it say [solved] if it is not yet solved?

Do not post solutions, especially if they’re from the course guides page.

The default code for this level also had an error (setGameState does not exist).

However, there also seems to be something wrong on this level, so I’m reporting it to the content team to take a look at it.


#6

Someone marked it solved even though it’s not solved I have no idea who.


#7

The owner of this topic marked it as solved.


#8

That means that it is solved scince he said that he figured it out


#9

So, he’s Solved it so no need to revive it.