Play Home Contribute Github Join Us! Discourse Staff Members Github Contribution Guides Team

[SOLVED] Vital Powers LVL won't Load

Hi I’ve been trying to reteach myself the calc based physics I needed to improve upon the greatest value function for picking up coins so that it would account for the coins on the way to the coin selected and recently had some breakthrough thoughts that got me back on track when when I ran out of time to work on it more. At this point I’ve had experiences in the past where leaving the level would cause me to lose all of the code when it wasn’t running properly so I ctrl+c-ed the code I hadn’t finished and closed the level to test and see if I needed to store it somewhere else to prevent this from happening again, but when I tried loading back into the lvl it loaded the bar to half way and stayed stuck there for 5 minutes. I’ve come back days later and it still isn’t loading past half way. I was wondering if someone could restore the level back to default so I can start fresh. I have a theory that the flaw in my coding I realized after the fact might have something to do with the bug since it was fine every time before I added it to the code. I was doing a for loop based on x position not taking into account when the hero was moving in the negative x direction and need to change it to work on position with respect to time instead. If this problem is more common than I thought and there are other fixes please let me know. I’m really wanting to get back at this.

Thanks

Okay I got back in. I think it just needed to run the loop out the maximum number of times before it would let me in. I’ve changed the code and it is loading much more quickly now.

2 Likes