Achievements Not Working


#1

Some of my achievements aren’t working, I think. For example, for the Complete 20 Levels Achievement, I realize that the number of levels I’ve completed is in the lower left hand corner (the flags). However, sometimes, when I complete a level, it doesn’t give me another flag. Example: I completed Siege of Stonehold, and nothing happened, but then, when I went on to the desert campaign, and completed The Mighty Sand Yak level, it gave me another level completed. Can anyone tell me what is going on? HELP!!!


#2

What browser are you using? It’s most likely because of your browser. I was having problems like that sort until I switched to Google Chrome instead


#3

I only use chrome and none of my achievments have ever worked so far. Still all unlocked but i’m max level and have beaten every current level :stuck_out_tongue:

so, needless to say the browser doesn’t matter in this case there’s a bug .


#4

Yes, I use Chrome also. They still don’t work…


#5

My achievements work on my account for python, but not sure about my JavaScript account.


#6

I use JavsScript on Google Chrome.


#7

We are talking about on the main “World” maps (dungeon, forest, desert). The achievement button on bottom right of screen. When you click it… you have a bunch unlocked? Mine is just the “signup” achievement. everything else is still locked. Not to be confused with the achievements area on the “profile” page.


#8

Yes, that is what we are talking about. I have gotten the first three achievements (signup, complete 1 level, and complete 5 levels), but now, I have completed all of the free dungeon, forest, and desert levels that are available so far, and it still says I haven’t completed 20 levels yet, which is the achievement I was shooting for.


#9

The number next to the flag in the lower left is your experience level, not the number of levels you have completed, although you’re not the first to understandably think that, so I think we need to change the icon.


#10

Oh ok, thanks lol. But still, I have completed all of the current free levels, and it still says I haven’t gotten the complete 20 levels achievement…


#11

Right, that achievement is not working right now: https://github.com/codecombat/codecombat/issues/1780


#12

I did not receive ANY achievement! (Not for sign up, nor for completing lvl 1, etc)
Through, I am already at desert “Sarven Shepherd” level, where to move further I obviously need a better gear…
What should I do?

(FF dev edition)


#13

Hey jokersoft, we’ve been making some bugfix improvements to this–can you let me know when the last time you beat a new level was?

Also, you might be able to get some gems now by simulating ladder games: http://codecombat.com/play/ladder/multiplayer-treasure-grove#simulate – let me know if that one is working for you.


#14

Last time was today, bout 3 hours ago. Before that - yesterday I almost did the whole game. Before that - 10th of Jan, tried some first levels.

I did simulate the ladders a few times (in the main game, some multiplayer levels), received nothing.
Hard to understand, where should I seek for the profit, honestly.)

On the “simulation” page you sent currently I am at the very bottom with
Games simulated: “empty”, Games played: 713, Ratio: “Empty”.

But will try now some more stuff. Will inform you if something…


#15

Yeah, looks like it’s still not working. I’ll keep on it.