Am I the only one who can't type in the editor


#1

Looks like a great concept - I was checking it out but when I get to the first “task” in the Beginners game, I simply cannot type/edit the ‘spells’ in the code editor window. I have tried this on both Chrome and IE (Windows 8.1 desktop) - the mouse seems to work fine, but the keyboard simply has no effect which pretty much ended my experience.

Any thoughts?
Thanks,
Bob


#2

Hi @bobwiller,

Did you click through all of the dialogues? The editor is disabled until all of the dialogues are clicked through. This is a glaring UI issue which we will fix soon.

Sorry about the bugs,

Michael


#3

I’ve updated the script that temporarily disables the editor to auto-continue after a few seconds, to make this less likely to occur. If you still see it, Bob, it would be awesome if you could include a screenshot so we could get it fixed–thanks!


#4

I too am having this issue. I am still on the starting “level”, in “Known Enemy”. I have let the script run and my hero dies and still can not type and correct the program. Sometimes it will let me add some text to the end of the code, but it will not allow me to edit the code. I want to add a loop, but it will not let me, I can not edit the existing code.

I see no pending dialogs or other items that need to be dismissed. :frowning:


#5

It seems to intermittent. I have tried other browsers, same result, so it must be the site. :frowning:
I will keep playing and will let you know what else. Anything I can do to debug or provide any diagnostics?


#6

Hey @Greg_Jewett, what I think you’re seeing is that you might be trying to type in the locked sample code area, which currently doesn’t have a very distinct visual marker (a dotted line around it). You want to type after that code area, to add onto the sample code to finish the level.

If that’s not it, please post a screenshot so I can see where you’re trying to type and what code you have and why it might not be letting you edit.


#7

Hey @nick - Yes, I learned about the “sample code”, as it will warn you and request that you reload the code - if some how you were allowed to edit it, which I think you are trying to prevent - which is being overzealous. Luckily I was able work around the issue I was having.

Basically - if you attempt to edit this code, it trying to lock you out, but at the same time, there must be a bug somewhere that keeps the lock in place when you are trying to type outside the sample code. Anyway, I had to completely clear my cache, quit the browser, log back in, and then it let me add to the code.

IMHO - Sample code should not be required, but allow one to edit it if they see a better way. I understand the who learning thing, but when I was showing my son (who is still learning), I was showing him it did not matter if you changed variable names, how you should not quote variables, etc… Being able to edit this code is important learning, EDGE method.

You should give the option to reload the sample code, but do not require it (I know this is a feature). Of course, do not allow (which I see happening is some code…) capabilities not yet achieved, ie the use of loops or object detection sub-classes.

I love the game! Keep up the great work! I am a stubborn full-time programmer… working with my son, challenging him to keep up with me, and teaching/helping him when he runs into issues.


#8

We’ll keep working on the UX there. We had to add the sample code lock because we saw, over and over, so many kids accidentally mess up part of the sample code (even with our “Oops, don’t delete the sample code!” script) and be unable to recover. But I see your point about limiting creativity…


#9

I am having the same typing issue. It did eventually let me type. I want to use this in a classroom situation, but not if its so glitchy.


#10

I noticed that i can’t edit my code after i once wrote it (on this level: http://codecombat.com/play/level/village-guard). Despite i can delete a text in locked area.


#11

I like the concept of this game a lot but the Keyboard bug is awful.

I have been trying to identify the cause of the problem but it still seems random. I am using firefox on two different computers that both have the same problem.

Originally i thought it was locking me out because the first line of code was running before i started typing and then failing the mission but I’m not sure that is the case anymore.

I have no open dialog boxes, i did not attempt to type in a locked area. It just doesn’t let me type at all.

In order to type again i have to wait for the hints reminder to pop or something else to come up to unlock the keyboard.


#12

I just finished a level and the “are you stuck” hint popped right before i hit “complete” or whatever it is to move on. I purposefully didnt click it to see if the typing would lock up on the next pass and it did. Could you see if this is one of the problems?