BUG - can't open the level


#1

Hey,

I click on the flag and try to enter Grim Determination level in Mountain world, but it just freezes. Tried other levels, everything works normal, tried to delete cache, to go to Firefox, but no success. It just freezes and doesn’t want to open and in Firefox it throws some error… It seems like it’s an infinite loop in my Codecombat code for that level, but I can’t even open it so I would reoad it…

Here’s the screencast https://drive.google.com/file/d/0B9vs9RxlIYARWmRBbXJRZ2FvaW8/view?usp=sharing (from Chrome)

I also opened a Github Issue https://github.com/codecombat/codecombat/issues/3571

Can somebody help me, please?


#2

Have you tried opening the level in another programming language? This will cause it to throw an error and not execute your code. Then you can comment out or delete your code and open it back in the original language.


#3

I changed the language to Python, then clicked the link and still the same. I also emptied the cache and doesn’t work :frowning:

I also tried with unequipping my hero to try to get the error (missing function) but it just doesn’t load. But I tried in Incognito window and it opens(but as soon as i log in, freeze…)


#4

This is now switched back to JS and it’s what console is logging…


#5

I am assuming you went through all the steps in the FAQ

There is not much more that can be done other than notify nick and skip to the next level while you wait for it to be fixed.