Criss-Cross level load exception


#1

I was trying out new code and restarted Chrome to test it and the level never finishes loading.

JS console was showing an error so I assumed I messed something up with the code I submitted.

I tried to start a new game as an Ogre, having previously only played as a Human, that resulted in the same exception.

Next step was to sign out and to spectate a game, this also resulted in the same exception:

Uncaught TypeError: Cannot read property '0' of undefined VM432:19
	Shoots.attach VM432:19
	a.exports.e.addComponents app.js:1288
	a.exports.e.deserialize app.js:1307
	(anonymous function) app.js:1430
	module.exports.World.deserialize app.js:1431
	a.exports.t.beholdWorld app.js:98
	a.exports.t.onWorkerMessage app.js:96
	(anonymous function) app.js:79
|Mog's Lana| And it was so: (2.132ms per frame, 1093 frames)
Simulation   : 2330ms 
Serialization: 52ms
Delivery     : 21ms app.js:83
Built sheet:  Wizard                 1754ms  Async   app.js:1717
Posted 1 error to errorception.com 51a79585ee207206390002a2.js:1

Now is this all on my end, could someone please reset my code for Criss-Cross?


#2

Tried spectating from Safari while logged out, results in an exception:

[Error] TypeError: 'undefined' is not an object (evaluating 'this.requiredThangTypes[0]')
	attach (undefined, line 19)
	addComponents (app.js, line 1288)
	deserialize (app.js, line 1307)
	(anonymous function) (app.js, line 1430)
	deserialize (app.js, line 1431)
	beholdWorld (app.js, line 98)
	onWorkerMessage (app.js, line 96)
	(anonymous function) (app.js, line 79)
[Log] |Anubis's Woodhouse| And it was so: (2.147ms per frame, 1006 frames) (app.js, line 83)
Simulation   : 2160ms 
Serialization: 137ms
Delivery     : 8ms
[Warning] 1 tags failed to render in 30000 ms (all.js, line 57)
[Log] Posted 1 error to errorception.com (51a79585ee207206390002a2.js, line 1)

#3

I’m seeing the same problem… I assumed it was due to my code submission but now I’m not so sure :smile:


#4

Just to be clear, this makes the game completely unplayable at the moment.

@Nick – poke


#5

Hey mdz, apologies for the slow reply. Nick is in the zone fixing several hundred bugs, I’ve filed a bug for him over here to get this resolved as soon as possible: https://github.com/codecombat/codecombat/issues/1509


#6

Hey @George – no worries on the reply. It looks like that particular bug did get fixed, or at least the level started loading sometime yesterday evening. However, it seems to be broken again at the moment. Thanks for posting the issue link!


#7

Yeah, I did fix this one, but there are some other ones now that we’ve merged in all the new stuff we’ve been working on. I’m working on these bugs today.