Docker setup with error: rbenv: not found

OS: Centos 8
CodeCombat Setup: docker

Log gose here:

[root@c8 codecombat]# uname -a
Linux c8.localdomain 4.18.0-193.19.1.el8_2.x86_64 #1 SMP Mon Sep 14 14:37:00 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux
[root@c8 codecombat]# ruby -v
ruby 2.7.2p137 (2020-10-01 revision 5445e04352) [x86_64-linux]
[root@c8 codecombat]# rbenv -v
rbenv 1.1.2-34-g0843745
[root@c8 codecombat]# docker -v
Docker version 19.03.13, build 4484c46d9d
[root@c8 codecombat]# docker-compose -v
docker-compose version 1.27.4, build 40524192

[root@c8 codecombat]# docker-compose up
Building proxy
Step 1/9 : FROM node:8.15.1-jessie
 ---> 27ea6de4c599
Step 2/9 : ARG RUBY_VERSION=2.6.1
 ---> Using cache
 ---> 13f1c54293a0
 ---> Using cache
 ---> 04f5a22811e9
Step 4/9 : WORKDIR /coco
 ---> Using cache
 ---> 01a1ec5cb37c
Step 5/9 : ENV PATH $PATH:/root/.rbenv/bin:/root/.rbenv/shims
 ---> Using cache
 ---> 982a4c41b40f
Step 6/9 : RUN apt-get update &&     apt-get install -y git curl libssl-dev libreadline-dev zlib1g-dev autoconf bison                        build-essential libyaml-dev libncurses5-dev                        libffi-dev libgdbm-dev &&     curl -sL | bash -
 ---> Using cache
 ---> 26e74d2d74c3
Step 7/9 : RUN rbenv install ${RUBY_VERSION} &&     rbenv global ${RUBY_VERSION}
 ---> Running in e66713108ded
/bin/sh: 1: rbenv: not found
ERROR: Service 'proxy' failed to build : The command '/bin/sh -c rbenv install ${RUBY_VERSION} &&     rbenv global ${RUBY_VERSION}' returned a non-zero code: 127

Hi @Jack_Martin, welcome to the CodeCombat Discourse! :tada:
I tried setting up CoCo with docker a few days ago and unfortunately it didn’t work for me either. I would recommend trying this method instead (it worked for me):
The “Simplified” Guide to Setting Up Dev Environment. (Mac)
However localhost:3000 didn’t work on Chrome or Safari for me. Apparently it’s a known error which has recently cropped up and the team will try and fix it soon.
Using the guide should get CoCo on your computer anyway, and when the issue is resolved you’ll be able to start doing whatever you plan to do with it. Also you could try Firefox which works for some people (I haven’t tried it yet).
If you have anymore problems I would recommend going to the development chat where they know lots about that kind of stuff:

Firefox is currently only supported at the moment.

@Deadpool198 Thx for the quick reply, but what I need is A docker env.

GitHub Issue Like