Dueling ground on run hero self destructs


#1

I don’t know if it’s a bug or not but it’s the first time I’ve seen this… the hero self destructs into small red pieces on RUN.

please see screengrab below

https://drive.google.com/open?id=0B19mmCKTPBRYcEtFVjJVeGhTMGc

more notes:
I restarted browser and hero is in pieces before doing anything
see screengrab
https://drive.google.com/open?id=0B19mmCKTPBRYWTQ0ai1kWURoRXc


#2

It looks like part of the sprite did not load correctly—the hero’s armor and hair is there, but the rest isn’t.

Try hard-reloading the game page (Ctrl+F5 or Cmd+Shift+R) or clear your browser cache to make sure it is not a cache issue. If the problem persists and you are familiar with browser DevTools, check the DevTools’ Network tab to see if there are any requests being blocked or failing.


#3

Hello @UltCombo

(logged in) ctrl +f5 = no change = hero DOA

I cleared the cache… and the sys dropped me to a new zero anon hero (and I was logged out) and the dueling grounds were functioning.

I logged back in and chose my hero

I went BACK to the dueling grounds

My Hero is DOA.

codecombat dev tools network is green but hero is still DOA
Here’s the vid:

curious eh?

What’s the next step?

thank you
Dennis


#4

@pleabargain Hey, that seems a bit odd, indeed.

I believe the HTTPS support is still being worked on, can you try to load the level via plain HTTP (change https: to http: in the URL) to check if it works this way?

Also, in the DevTools’ Network tab, you can tick the “Disable cache” checkbox and reload the page to be extra sure it isn’t one of those pesky cache issues. :smiley:


#5

@UltCombo
re: https
Tried it. Still DOA.

re:diable cache
Tried it. Still DOA.

re: errors
I’ve got an error at the bottom of the load
"Cannot show action teleport for Captain because it DNE"

test: Could it be my code?!
loop:
# Find and attack the enemy inside a loop.
# When you’re done, submit to the multiplayer ladder!
enemy = hero.findNearestEnemy()
if not enemy:
hero.moveXY(44, 38)
elif hero.isReady(“cleave”) and hero.distanceTo(enemy) <10:
hero.cleave(enemy)
else:
hero.shield()

And FYI forrmatting code in this forum does not appear to work either… :frowning:

Yes! My hero is back after I removed the above code… so, what’s wrong with my code that it would cause my hero to be DOA?!

More on the shield blob on DOA. My hero animation passes via a shield blob
See the video

thanks,
Dennis


#6

Re: formatting
When you are creating or editing a post, select the code and click in the </> button. See the FAQ for extra code formatting tips.

Oh, I finally managed to reproduce the issue! Looks like the problem is specific to Anya’s animations (shielding and attacking) in multiplayer (“ladder”) levels. I was previously testing with Tharin and couldn’t reproduce the issue with him.

Thanks for taking the time to report this issue and putting up with all this testing! :smile:
I’ve reported the issue in the CodeCombat repository, here.


#7

@UltCombo
Many thanks to you sir!

I appreciate your patience and support!

There should be a tip jar here! :slight_smile:

Dennis


#8

That happened to me once when I was playing multiplayer. Im like, “WUT?!:confused:” and then im just, “oh its just a glitch. :sweat_smile:” But I just DEAL WITH IT.:sunglasses:


#9

Yeah, it is not a game-breaking issue, but in any case it is a bug and needs to be fixed.