Dungeon - Cupboards Of Kithgard


#1

Hi Code Combat Support!

Here’s another bug!
If you can take look at the below picture, there will be an problem after the execution of my last bit of code.

Now I was thinking I would stay in the room with the cupboard.
If you are wondering if the hero got pushed into the hallway by the skeleton, then I’d have to say that’s not the case.
My hero literally walked into the hallway yet I don’t see in the code how the hero would want to go there.

I have even tried not using the while loop and still same results.
Now the… What do you call those blue guys again??? XD
They didn’t attack so probably anyone newcomer might survive.
Except if they get hit by spikes… I know I did.

Any suggestions?


#2

You have to put the attack in the while loop, so it means when an enemy is around your hero will attack it, and everything else it outside of the loop. so if you did that, it’s right.


#3

I guess it’s a bug then XD


#4

It’s not a bug, your hero is supposed to be like that, so when you broke that cup, right after that you were supposed to do nothing, so skeleton attacks the ogres.


#5

Really? Let me try to specify. If you take a look at the last picture there is a target mark where the hero is heading towards to. I do believe there is no such code that commanded that hero to move there.


#6

You moved down two times to the mark.


#7


If I move three times I’ll walk into a wall and if I walk once I’ll attack the cupboard from the hallway.
So if you mean that I would return to the original spot before the hero.attack(cupboard); , that does not seem to be the case.


#8

Hey, just wanted to let you know that you can use hero.moveDown(2); to move down two spaces instead of just one. I think this is a new thing that was released while you were gone.

The correct amount of moveDown is 2. Not sure why it would move back up (yep, sounds like a glitch), but as long as it’s setting the goal to success, probably not a big deal. When I use the exact same gear, my hero doesn’t move up after attacking the Cupboard. This usually indicates that it’s something having to do with your gear.


#9

Nice investigation skills man XD.


#10

I dont really know if its a glitch but I replayed one of these levels with my current gear. When I first did these levels I had to use the attack method twice on an enemy. When I used my current sword that can now one hit an enemy he also tried walking into the wall.

You have to realize these levels were made with the intentions of new players and weak gear. As you move on to the forest you will soon have to start using algorithms to check and see if their are any enemies before you attack.

if Enemy:
   hero.attack(Enemy)

If you dont like that your hero is walking into the wall. Look to see if their is even a “Cupboard” before attacking.


#11

@Ty_Ler Looks like your right!!!

I used all low level equipmet!!!
Except for the other equipment types people would get at higher levels XD


#12

you could do it with ashort sword


#13

you could also do it with a boss star


#14

Not sure what this has to do with this topic.
Also try not to revive dead threads :slightly_smiling_face: