Dungeon Stuck on Ready


#1

Trying to launch the multi-player dungeon arena and getting stuck at ready.

Chrome console shows:

Uncaught TypeError: Cannot read property ‘start’ of undefined aether.js:2530


#2

How about now? I’ve just done a deploy; this might have fixed the issue. If not, can you let me know what code you are using, or if you can’t get to it, your _id?


#3

Apologies for not responding sooner. I worked around the issue and was busy playing :wink:

The issue appears to be tied to an issue with Google+ login. I can’t login directly via Google, BUT I can go through the recover password option, get a temporary password and then login via email (using the Google email address).

That’s when I get the issue mentioned above, which still seems to be happening. I suspect if I could login the “correct” way via Google+ it probably won’t happen.

In the meantime I’ve signed up via a different email address and am busy crushing humans.


#4

its happening to me too.

my id is 53315528c3fd5cda6439db43

I think it crashed while half way through editing my code, so the code is probably broken


#5

@Frazer I think I’ve fixed some bugs with this. Is it still not loading? If so, let me know which ladder (ex.: Dungeon Arena humans).

@steverb It would be really strange if this was directly caused by the G+ login issue, which I haven’t fixed. But have any of my other fixes helped on that other account?


#6

Your fixes appear to have worked on that account too.


#7

still freezing for me

level/dungeon-arena?team=humans

plays sounds of whistle and the voice says code combat
the load bar fills all the way across with green
sounds goes dun dun dun dun dun

then nothing


#8

Found the problem there and fixed it. Something was going wrong in the AI for defending a target position.


#9

thanks, its working now.

maybe the timer for being stuck on the loading screen should override everything else?