Is there a help/solution-option in the game?


#1

Hey everybody,

I am totally new here and also not from the development-field. I am working in a software company, but in a totally other area (Sales :slight_smile: ) ;-). Still have fun with “playing” the game and learning a little bit coding.

But I have really problems to understand what to do. Not the coding itself is a problem, but the description of what to do. Is there a help-option/ solution-option for the levels?
E.g. in level: “dungeons of kithgard” - there are no coordinates to move to. I can’t go further and don’t know how to go on. If I don’t get help/ solution, I have to skip the game, which would be very sad for me :-(.

Hope you can help me or tell me how you solve it if you can’t find a solution for a level. Thanks and greetings, Eymee


#2

There is a Guide tab in the Game Menu at the top of the screen. We have considered populating it with hints, but we haven’t gotten around to it to see whether it helps players.

In Dungeons of Kithgard, you just moveRight, moveDown, moveRight–don’t need coordinates yet with the simple boots.


#3

Ps: I am using Phyton. :wink: Think, you must know that to help me.


#4

Hi Nick

thanks for the tipp :-). I found the guide tab.
But unfortunatelly also the orders “moveRight”, “moveDown”, “moveRight” are not working :-(. My hero doesn’t move at all! I also tryed “self.moveRight()” and so on which was given by the game itself as an example. But one second later the game says automatically (before I tip any code): “moveRight is not available in this challange. Line 5, time 0:0, tmp5 (tmp6) is not a function.”

I am a bit frustrated because I am not sure if it is my fault or if its a bug.


#5

It s me again.

I have read: SIMPLE SHOES. I weard my leather shoes. But how the hell should I know which shoes I need?? The game automatically gave me the leather shoes and I didn’t think about wearing the other one.

Maybe thats a hint for you: if “not-developer” play your game, it is not so easy to understand how to play the game, e.g. the shoe-problem. In my opinion I could not know that I had to change the shoes to move on in the game. Maybe you can give a more detailed guide/ help-programm to motivate people who have problems in the game :-).


#6

It shouldn’t have automatically given you the leather boots; it should have automatically given you the simple boots, so that is the bug. What did you do first in the game that you got the leather boots first? Hoping we can fix this one!


#7

Uhhh, I don’t know anymore. I thought it gave me the leather boots on its own. Sorry that I can’t reproduce the bug/ process.

Thanks for your help and the tipp with the guide, so now I know where to get the first information if I don’t know how to go on :-)! Great!


#8

But I have seen the guide is not in every level, is that right?
Some levels are very easy, good to train the coding. Some are, of course, a bit tricky, so a guide would be fine :slight_smile:


#9

You have a good point .We have put it on our TODO list to add guides to the existing levels to help with hints there.


#10

Would be great to have some help-options. The game is really great to learn coding :slight_smile: - I have much fun with it. But there are many little bugs which makes it difficult to solve the levels. I am never really sure if its my fault or a bug. E.g. yesterday I was sure about my solution but it didn’t worked. I had a look on a website which have the right solutions for each level (https://gist.github.com/a1ip/2ea627a4bf6067a63634) and it was exactly my way of solving. I went back to the main menu, started the level again and then the game asked my to take the sword with my hero. So it worked :-). First it didn’t give me an arrow to take the sword with me, so I didn’t. Also a bug in the forgetful gemsmith-level (black and white tiles). So that makes it a bit difficutl to play. Hope, you can fix theses buges and it will be a very great game :-)! Go on! thumbs up