Pointless Robot - speed of Goliath not saving


#1

Hi All, I cannot seem to get off Pointless Robot. I am not certain what I am doing incorrectly, but no matter how I configure the speed of Goliath, the system does not seem to recognize that I have. Looking at Goliath’s properties it seems his maxspeed is 4, which I have observed. Unfortunately, I cannot move up a level until I resolve this. Thank you for any help you can provide.

message : “Goals incomplete configure Goliath’s speed”

#excerpt 
game.setPropertyFor("goliath", "speed", 4)

#Entire code  
# In this game, the goliath must survive for 15 seconds.
# Read and follow the directions to spawn obstacles he must avoid.
# Review properties by adjusting his speed.
# Then click PLAY to play the game!

# First, we set up the environment:
game.spawnFloor("desert")
# You can spawn borders for some sides and not others:
game.spawnLeftBorder("forest")
game.spawnRightBorder("desert")
# "warp" makes the game field wrap around:
game.setBounds("warp");

# Now you try. Spawn more decorations.
game.spawnDecorations("desert")
# Now you try. Spawn more decorations.
# Try a different type, like "forest", or "glacier":
game.spawnDecorations("forest")

# spawnRandomly spawns objects at random coordinates.
# The number tells how many to spawn:
game.spawnRandomly("robobomb", 10)

# You try! Spawn some random cows:
game.spawnRandomly("cow", 10)

# Next, we need a hero, of course:
game.spawnPlayerXY("goliath", 42, 36)

# Let’s review properties.
# This sets properties for the robobombs:
game.setPropertyFor("robobomb", "speed", 5)
game.setPropertyFor("robobomb", "behavior", "Scampers");

# Your turn - set a speed for your "goliath":
game.setPropertyFor("goliath", "speed", 4) 
game.setPropertyFor("goliath", "behavior", "AttacksNearest");
# Finally, we write the goal and the directions:
game.addSurviveGoal(15);
ui.setText("directions", "Avoid the robobombs for 15 seconds.")
ui.setText("directions", "Use 'WASD' keys, mouse or touchpad to control the hero.")

#3

His code is correct. He got it. There’s a problem with his level. I tried copy/paste the code in the level and it worked. This only updates once you die, or survive. @Jaxlee2018, do you mind trying this out again? And see if it updates after you die? (Or survive)


#4

Thank you Puppet_Chaboi, that is exactly why I posted, whether I die or survive I can’t get off this level due to the fact that it believes I am not giving Goliath a speed. So I can’t be the first person to encounter this bug, how do people bypass this level (or any level for that matter once you feel you have met the code challenge ).


#5

Have you tried changing the goliath speed to something like 19?