The is a glitch on The Second Kithmaze please help!


#1

I cant get past that level… i know how to do it and i am using 5 lines of code but it says that i am using 6 lines and makes me fail. my code is:
loop:
self.moveRight()
self.moveUp()
self.moveRight()
self.moveDown()
that is clearly 5 lines of code but it still says that i need to use less than 6 lines of code!!! this is so frustrating i have been trying to solve it for about 2 hours omg!


The second Labykith
Haunted Kithmaze broken in Python
#2

I just tried your code and it works fine here.
Make sure you don’t have anything before the loop or after it. Otherwise, try refreshing the browser to see if it helps.


#3

I have a same question too


#4

I have the exact same problem. No code before or after - tried using both loop and while True. Have refreshed browser and deleted cookies on 3 different browsers. Went back to Haunted Kithmaze, and even though I got through on first attempt, the exact same code started failing on this level too.


#5

I have the same problem as do all of my students. Is there a way of going around this task?


#6

I have the exact same problem and so do the students. The code mentioned above worked fine yesterday


#7

I personally still can’t reproduce the issue, perhaps due to a CDN cache layer or because I had already beaten the level.

Anyway, this seems to be a real and serious issue. Let’s summon @nick for his arcane magic.


#8

It makes no difference if you have passed the level before with the correct code, it keeps saying it is ‘Failing’ - I have pupils at this level and unable to pass. They are writing the code correctly using a Loop, but it’s telling them to use a ‘While Loop’ which we have all tried and it still doesn’t work. All code is written under 6 statements as required. Very frustrating, as they are unable to move on!


#9

Sorry, all!

We recently made some changes in an attempt to make line counting work better. I’ve reversed the change for now until we can further investigate this issue.

It may take some time for the fix to get through the cache. In a pinch you can try playing the level through direct.codecombat.com, which may be slower, but should already have the fix.


#10

@Sioned_Weeks Oh, I see. Thanks for the details. I believe I was not able to reproduce the problem due to a CDN cache issue. Note that I didn’t intend to sound rude; I’ve acknowledged there was a real issue and merely stated that I could not reproduce it (even with my browser cache disabled), which may be a symptom of a secondary issue (outdated/cached CDN content perhaps).

@Catsync Thanks for the quick fix. Also, although this seems slightly unrelated, I’d like to mention that direct.codecombat.com does not work if you are accessing from an area that has a dedicated CDN (Brazil, China), as upon trying to load direct.codecombat.com it will immediately redirect to the region-specific subdomain (e.g. br.codecombat.com). I thought I’d just bring this to the CodeCombat team’s attention in case you were not aware of that yet.


#11

C’est la même chose pour moi. Je bloque sur le Bonus de niveau.

It’s the same think


#12

Thanks for fixing the problem, but still saying the same as yesterday, I have reloaded and done the code again, and also logged out - refreshed the browser! Should it take 24 hours? As it has been nearly 24 hours - I am resorting to my pupils going back to Kodu - which I don’t like! Thanks


#13

It’s working now - please ignore previous reply. Many thanks - phew! We are loving it!!


#14

this level is EZ all you do is walk


#15

my code is
while True:
hero.moveRight()
hero.moveup
hero.moveRight()
hero.movedown
but it is not working and I have tried it several times and is noot working and I tried 2 refresh 2 times


#16

@Catsync

     Thank you I have been trying this for at least 5 hours so I say again thank you 

how far have you gotten because, this is still not working, thanks again please @ me please!!!


#17

It will only let me walk right so yeah please reply with an answer.


#18

Remember how to call a method, you need to use ().