A Fiery Trap - no shield


#1

Don’t know if these are fully available yet, but seemed to be, so I thought I’d give it a go. However it looks like you need a shield to start, but I couldn’t see a shield to equip?


#2

You don’t have the wooden shield? Should’ve gotten it on one of the earlier missions: Closing the Distance. You could try playing that one again to see if it gives you the shield. Let me know if not.


#3

You’re right, it is a reward for that level. So possibly I have a shield, but it doesn’t show up in my list of owned items. Clicking on it in the Fiery trap level (i.e. the box to the left of the character in the equip screen) seems to do nothing, clicking on it on other levels opens up the left hand items, but they are all shown as locked. User mattharr if it helps.


#4

Do you have the shield now? I just recalculated all the rewards.


#5

I think that did it. I see the equip screen has changed now - looks good.
I ended up buying the shield and belt with crystals, but that all worked then.
Seems an odd name for that level now, given that you seem to be using a sword - not much fire when I played through :smile:
When I started the javascript looked a bit odd - I put a patch in for that. The goals also look a little odd, they all have numbers? They came up as successful, but ''Ýour hero must survive. (3/3) ‘’ Looks odd I think.

Otherwise quite a nice level using looping and if blocks.


#6

Later today, we’ll reset all the purchases due to some bugs, and you no longer can buy the items you’ll be awarded with gems (so as not to waste them).

I’ve renamed the level, accepted your sample code patch (thanks!), and fixed up those goals. Really appreciate the playtesting feedback!


#7

Hello guys, really nice game with nice user story. But i’m really stuck on that shield rush level? how to use that shield?
If i’m trying to use it as self.shield(), it says that there no fucnton like shield(),
Can comebody sudgest me what is the problem? Thank you!


#8

Have you equipped a shield better than the wooden shield? All of the shields past that should give you the self.shield() ability, and it should have awarded you a bronze shield just before to use with it. (But that may not have worked due to a bug we are having with unlocks.)


#9

I think we have the fix, but in order to get the experience, gems, and items from the levels you beat between last night and this morning, you’ll have to go back to each level and click “Done” again so that it can correctly record your victory. Sorry about that!


#10

Yes, no problem, it’s so great that you guys doing so nice job! Way to go!