[Adventurer] Throwing Fire


#1

The level Throwing Fire is ready for playtesting!

This level takes place in the Game Dev 1 campaign. It introduces the "fire-spewer" and gives practice with using property assignment to configure game objects.


#2

Completed without issue. Its a good idea for a level and you should make a follow up level with the same concept but the hero must change some spewers to horizontal and some to vertical to get the right combination where the hero can pass harmlessly.


#3

Easy and amazing level, thank you! :smile:


#4

I’ve just started here, but every time I try to load “Throwing Fire”, I get the following error:

Unable to Load Level
The initial code to build the world never finished running. It’s probably either really slow or has an infinite loop. Or there might be a bug. You can either try running this code again or reset the code to the default state. If that doesn’t fix it, please let us know.

You can also open the developer console to see what might be going wrong.(instructions)

I tried it in both Chrome and Edge, and had the same issue, I also tried using the buttons “Comment Out My Code”, “Reset Level”, and “Try Again”.

Little Help?

Thanks,
LeRoy3rd


#5

I once had a similar issue with Grim Determination. Try reloading the tab or clearing your cache.


#6

I’d already tried closing the browser (and using Edge as well, which I’ve NEVER used, so, there would be no cache), but I also cleared the cache in Chrome, restarted my computer, and tried again, to no avail. :’(

Any other ideas?

Thanks,
LeRoy3rd


#7

Hmm…Have you tried any other browsers besides Chrome or Edge?


#8

I think this should be fixed now. Try again? You may have to clear your browser’s cache to make sure you get the fix.


#9

It is (fixed now)! I installed Firefox, it didn’t work, refreshed, then it did (on all browsers)… I was so confused. LOL. Thanks so much for taking a look. Also, a quick question… I finished the level, but I wasn’t sure what it expected on the first line with the yellow arrow… I couldn’t actually get any of the game assets to load when testing the level until I commented out “return” from the top. Not sure what I’m misunderstanding, could you give me a nudge in the right direction?

Thanks,
-LeRoy


#10

The return at the top was probably added when the level wouldn’t load, if you pressed the “Comment out My Code” button. Normally that return wouldn’t be there, so removing it is the correct thing to do.


#11

LOL! Yeah, of course! Feeling a bit dumb now, but at least I’m not going to be banging my head against the wall trying to figure out what I misunderstood.

Thanks,
-LeRoy