Backwoods Brawl locked up after level completion


#1

Submitted the code successfully, but got locked up on this screen:

I closed the window, reopened codecombat, and it showed the level completed. I have no idea if it calculated the XP and gems as I don’t know what I had going in.


#2

Same here at Sarven Brawl (equal game mode):

Workaround:
Press ESC and submit it again.


OS X 10.10.1
Chrome 39.0.2171.95


#3

It did the same thing for me. I didn’t get XP or Gems from it, as I knew what my gem count was before beginning the level. The gem count was unchanged after quitting the window and going back in.


#4

yeah its happened to me on every single repeatable level so far. :slight_smile: i figured i still got the reward i never compared before and after


#5

It did it for me also the first time I submitted. The second time I tryed, I was able to click on “saving progress” and it started to count gems and Xp. And then the level become far more difficult, so I suppose it works well.


#6

Sorry I haven’t been able to get this one fixed yet. I’m tracking the issue over here on GitHub

If y’all could open the JS console and see if there are any errors when it happens, it might help. (One player already tried this but didn’t see anything weird.)


#7

Same thing happened to me on both Sarven and Backwoods brawls. I didn’t get gems in either case.

Not sure if this is helpful or not but I noticed that after I left and returned that a “1” appeared at the top next to Sarven/Backwoods Brawl. In one case I was able to complete the level again though it was harder and I did get credit (in the other one I died).

So it seems like the bug is with the “0” level of the brawls but not later levels?


#8

Oh, you know, that might be! Let me check that out.


#9

as @nick finds a { missing its partner, somewhere in the code…


#10

In my case it happened at Backwoods Brawl and Sarven Brawl and Backwoods Treasure!.
Not only at the first level but also at further.
I have noticed three possibilities of ending level:

  1. I got full revard
  2. I got no revard.
  3. And new one: I got exactly half revard (checked with diamonds).

#11

I’m having a really hard time reproducing this bug. If you’re seeing it, please let me know:

  1. What browser(s) you do/don’t see it in.
  2. How fast your internet connection is.
  3. What difficulties you have and haven’t seen it on.
  4. Whether you ever see achievements fail on a higher difficulty after succeeding on a lower difficulty.

Thanks! By the way, when you earn a replayable achievement, it might say, like, +600 gems, but it will only be adding, say, +250, if you had already earned +350 of them from beating it on the lower difficulty. I need to tweak the UI to start from where you left off rather than from the beginning when counting up the gems.


#12

Hey Nick happening over here to, really needed those gems to handle Sarven Sheppard. Might ask you to reset my gems due to buying a wizard early on that I should or not purchased. Currently doing the level on chrome with and internet connection of 23 mbps. I have seen few difficulties with the game except on this level. Also the flag went up with no gem reward or xp reward. Escaping out changed the difficulty when I resubmitted the code.


#13

Hi Nick!

This just happened to me. Google Chrome, 23 mbps, first time playing Backwoods Brawl. The first time I survived, but it locked up on me and showed the exact same screen as above. I hit esc and tried to submit again, but I died the second time. I hope this helps…

P.S. First time posting, nice to meet you!


#14

Hi @nick,
In backwoods treasure, it happened again : first time success, the “saving progress” was grey out, impossible to select.
I refresh the level, and then it endings with a normal finish, not with “saving progress” button.
Then I switch to level two but fails (did you see the number of enemies ? B ° )
Chrome, fast connection.


#15

Hey so don’t worry about resetting my gems. I really support the project; I am just going to buy some. Thank you for this awesome resource.


#16

I don’t remember which difficulties this happened for me. I have since beaten any of the levels at some point. I’m using Chrome and very good internet.