Cannot enable Multiplayer for Gridmancer


#1

I tried enabling Multiplayer for the Gridmancer level, but nothing happens. I did the following:

  • Start up Gridmancer which loads the level successfully (and shows my completed code).
  • Click on Multiplayer button on top of the level UI
  • Click on the checkbox to enable Multiplayer
  • Click the Close button

Nothing seems to change. When I click on the Multiplayer button again at the top of the UI, it shows the checkbox as unchecked as if nothing happened. I also tried clicking Restart and then enabling it, but no luck there either. Here’s all I see after I click the checkbox:

I noticed when I clicked on someone else’s multiplayer link (that I found in another post on the forums) that the dialog box shows the multiplayer link in it but mine does not when I just enable multiplayer from the Gridmancer level.

Running on Chrome Version 31.0.1650.63 (Mac).


#2

Hmm–do you see any JS errors in the Chrome console when you try to click the checkbox? You can press Cmd + Option + J to pull it up.


#3

Unfortunately, no. I cleared the console, shift-reloaded the page, clicked on the Multiplayer button, clicked the checkbox, and then clicked Close. Saw nothing. The only output appeared during page load:

I also tried on Firefox (Mac v25.0.1 and also Ubuntu 12.04 LTS, v26) and for some reason the dialog box itself is not even responding correctly (cannot close the dialog with the Close button or pressing the X in the upper right corner of the dialog box).


#4

I see the bug; not sure why it’s not firing anything. Debugging now.


#5

I just found some bugs and fixed them–should be all set now. Thanks for helping debug this one!


#6

Brilliant. It’s working now!