Feedback: Closed Crossroad


#1

Shouldn’t a hammer be required, and perhaps flags banned?

My hero keeps building fences after one has been built, wasting time. This can be solved using the isPathClear function, but I don’t it’s likely that players that early will necessarily have access to it. Sometimes, a peasant comes at the same time as an ogre on a fire-trap location. (Also, it is hard to find a distance that keeps from building traps at the wrong place when an ogre is coming from a different direction, yet will still stop all coming ogres, even with the Ring of Speed. Could this be specified in the guide?) I finally beat the level with a rather complicated solution involving chain-lightning, the Ring of Speed, and isPathClear.

(I’ve submitted a patch to correct what is presumably an erroneous function in the guide.)


#2

Through wall glasses?

Hammers should be required. About flags - it’s forest begin level.


#3

I’m actually using the Enchanted Lenses. They have the function and unlimited range, but can’t see through walls.


#4

Then it’s weird. Maybe you are too fast? “Speed ring” or a speedy hero?


#5

I am using the Ring of Speed, but it didn’t work without it.


#6

What do you mean “it didn’t work”? Could you give your session ID for the level? To get it - open dev console and find a string like this:
Generated random seed 2452538293 of type submissionCount from sessionIDs 5799xxx2d124a2401f0046dc2b submissionCount 3


#7

Sorry for not getting back to you sooner; I’ve been a little distracted. Thank God for Saturdays.

I still can’t find the right distance so that my hero builds traps when he should, yet doesn’t when there’s an ogre coming from a different direction.

Is this it? |Prometheus's Pam| Generated random seed 1953528879 of type submissionCount from sessionIDs 5796912d9dacc21f00b37f82 submissionCount 6


#8

Thanks. It’s weird. Because I get the success with the same equipment and the same code. I think it’s the random seed which affects the ogre (one from the top) behaviour.
I’ll fix it tomorrow.


#9

Could you try it again? I’ve changed a pattern and it should be ok now.


#10

It worked! Thanks much!