Level storming the towers of areth


#1

Two remarks:
The hammer is not required even if it’s needed for this level.

The wooden cross on the far left is not visible at the begining. Maybe it’s a wanted feature, but we’re looking for it when we’re writting code a little bit in advance.

Regards,
Vettax


#2

The x’s appear as you need them at each point in the level. They are not there all the time. It’s intended.


#3

Are you sure the hammer isn’t required? I think I’ve configured it properly to require the hammer…


#4

I was sure, but now…
At least now it’s requiring the hammer to me.
Is the way we start the level using the shortcut in the email could lead to such problem ?
I’m not sure but it seems to me the first time the code complains about the buildxy method because of the lack of hammer…


#5

I concur with Vettax, there is no hammer req. At least on the initial load.

Also the “far left” x has not appeared during three plays. I have tried different locations of the last two fire-traps but to no difference. So I can’t complete it.

Lastly in a stylistic sense the humans overwhelm in combat, this seems to thematically detract from the objective of booby traps.


#6

@sotonin have you seen this kind of problem?


#7

The “far left” x appeared finally. Maybe there was something special about where or when I was executing the string. But when I re-wrote all my code, no problem.


#8

No, i have not ever seen the x not appear.


#9

Same issue for me, I have tried different ways and characteres but I don’t see the final X to run to


#10

Try posting a screenshot to show what you have done in the level to get into this state.


#11

Thank you. I already found it, It’s a {x: -16, y: 39}


#12

I think the problem was that the camera boundaries make it hard to see the X if your hero is still on the right side of the screen. To get around this, I edited it to add an intermediate X that is definitely visible, and to accept it if the hero moves to either X.

Also, another player had an issue where his traps weren’t exploding, because instead of going around the back, he was running straight through the battle to get back to camp. I suppose this isn’t as much of an issue, but if any other players have that problem, try returning the way you came after building the traps.


#13

Hi all,

sorry I don’t knwo, how to win this level.

What is wrong with this code?
I can’t find the rally point.

this.moveXY(55, 14);
this.moveXY(92, 9);

// Build a "fire-trap" on the red X.
this.buildXY("fire-trap", 93, 19);
// Move back to the wooden X to avoid the blast.
this.moveXY(80, 5);
// Wait for the peon to investigate the shiny fire trap.
this.say("Muhahaha");
this.say("Prepare to die!");
this.say("What did the fox say?");
this.say("Who let the dogs out?");
// Enter the camp and lay fire traps on each red X.
this.buildXY("fire-trap", 90, 53);
this.buildXY("fire-trap", 60, 63);
// Yell for your troops to retreat. (Hint: use say.)
this.say("Come get me!!!");
// Flee back to the far left wooden X rally point.
this.moveXY(80, 5);
this.moveXY(-16, 39);

#14

Try using the string "retreat" instead, I think there are only a few orders your troops will understand after you place both traps in the camp.


#15

Wait, what!? follow directions??? . . . . Nah…

// Yell for your troops to retreat.

Never crossed my mind to say anything but “Retreat” . . . as it doesn’t say, “yell at your troops” or “speak nicely to them” or “start up a conversation” or “insult them” or “provoke them” . . . . . :wink:


#18

Are you saying you didn`t see a X before you ran the code or after you ran the code? Could you send a picture of the place where the X is supposed to be?


#19

Vadym has already solved his problem. Please refrain from posting to problems that have already been solved.


#20

I`m sorry I will try not to