Level not loading


#1

Wanted to play tonight and just logged in. Last time I played, I completed Rich Forager (after the bug was fixed to purchase armor). When I log in now, all levels above “Deadly Pursuit” are locked. If I re-submit “Deadly Pursuit”, the game takes me to “Multiplayer Treasure Grove” (http://codecombat.com/play/level/multiplayer-treasure-grove). This page loads about 20% and then hangs. Any suggestions? I’ve tried typical troubleshooting… Chrome and Safari browsers / reboot, etc.


#2

Multiplayer Treasure Grove is pretty buggy sometimes. Do you get any messages in your JS console when it dies? https://developer.chrome.com/devtools/docs/console#opening_the_console

You can play Rich Forager directly by URL like this: http://codecombat.com/play/level/rich-forager

The other locked levels on the map are not done yet, but will be soon.


#3

Doh, didn’t think to look at the JS console until you mentioned it. Thanks. Seems there is an error while loading. Something about an undefined property in firebase.set. Here is a screen shot of the error. I hope the resolution is good enough to read…


I tried reproducing the error and got this the second time around… (the uncaught error seems consistent)
Any suggestions would be appreciated.


#4

Ah, that makes some more sense, sort of. Tracking it here: https://github.com/codecombat/codecombat/issues/1784


#5

I think this is fixed now. Well, at least I can load the multiplayer treasure grove game.