Mine Sweep Bug with Jumping Boots


#1

Earlier today I found that if I used (in Javascript) “move” on the jumping boots to the nearest coin, I wouldn’t trigger the mine underneath it.

When I switched back to leather boots, “moveXY” worked as I expected.


Move method stuttering when MoveXY does not
#2

Could that be because the jumping boots would make you “flying” which would not trigger the fire-trap below?


#3

In theory, that would only happen with “jumpTo” rather than “move” though…


#4

Ah, I see the problem. I’ve pushed a fix such that the fire traps don’t require such exact positioning when using move instead of moveXY. Better now?


#5

Yup it works now. :slight_smile: It also shows the differences between “move” and “moveXY” really well.


#6

Right, except I still need to fix https://github.com/codecombat/codecombat/issues/1787 so that move isn’t super choppy.


#7

Yes… I also haven’t looked into yet if I can check what “action” my character is currently in the middle of performing. If you look at the Mine Sweeper, he whines for healing like a true MMOer, instead of just once.

Speaking of checking things on the character… pos, health, etc. don’t seem to actually require a necklace - and no quest grants an initial necklace. Likewise, the “code” books don’t seem to actually grant access to “if/else”, as you can use them before you have a book.


#8

Most actions, your code doesn’t run while you are doing the action, so it wouldn’t be very helpful to check the action property. There may be some cases where it’s useful to see what action you were just doing, though.

Some day I will make it so that those items are actually required, but it doesn’t seem to be a big problem now, so I haven’t gotten around to locking those properties down yet.


#9

Just a link to another thread about the choppy behaviour of move.