Problem with move() action?


#1

There are two different movement methods on two different pair of boots (one I got during campaign, other bought): moveXY() and move().

moveXY() works as expected, but move() seems to have some issue — character is moving much slower and kind of shaking as if undecided what to do. I ran out of time for coin collecting several times in a row, just because of that.

The methods seem to be identically documented (other than taking arguments differently), so I am not sure why the difference?


#2

Yeah. i posted previously about Move and MoveXY… the bug still hasn’t been fixed… i have 2 pair of nicer boots i can’t wear because of the bug.

i to am unsure why they felt the need to make another function that does the same thing but only takes arguments differently. seems kind of pointless overall.


#3

The moveXY() version is easier for walking around, move() is easier for item gathering (can pass item.pos rather than write it out).


#4

That’s the only difference. But still not really any easier. you can easily pass in item.pos.x, item.pos.y into MoveXY() as well. :slight_smile: it still seems pointless to me


#5

I still have that bug high on my list to fix after the Hour of Code rush dies down. In addition to being easier to do math with, the objects defined in move have some additional methods, and also move only moves toward your target position, not all the way there. So it’s easier to change your action in response to new conditions. But we haven’t made levels that formally introduce that mechanic yet. When we do, we’ll probably rebalance the more powerful boots so that you wouldn’t tend to buy them before you got that far and knew how to use them. (They’ll also get more expensive.)


#6

That sounds very nice. So you would be able to “break out” of a move action to say change course and go after a gold coin that just spawned on your head? How would that work? I’ve been trying to figure out a way around that particular scenario and short of recreating a movement / pathfinding system haven’t been able to pin one down yet.


#7

jump() on those boots is pretty weird too btw. The benefit over walking isn’t obvious.


#8

So @nick are you saying we should buy the boots now before the price goes up?


#9

Nah, because they are buggy now! Also if the price changes, the way that it’s currently set up, you may eventually end up paying the changed price–not sure, we haven’t ever done a purchase recalculation, but we might once we start messing with balance.


#10

oh, that could be dangerous. If that is the case you might need to offer everyone a chance to sell back items at full price for a while after the price increase (or just remove all purchases and refund gems).


#11

Yeah, we’d want to make it easy to change your buying decisions if you got hit by a big item price change. We’ll cross that bridge when we get there, but I wouldn’t worry.


Problem with move(targetPos) Javascript
#12

It’s in worse shape than it was the last time i checked it!

I tried defensive boots, boots of leaping and boots of jumping. Now it hangs on the move command but does not move. completely utterly broken :frowning: