New Level: Cavendous Canyon


#1

Hello,
I have a new level ready for playtesting, please take the time to play it and any feedback is appreciated:

Enjoy!

Endercore79


#2

Interesting. However, your level does not scroll, nor does it show the full extent of the map. Why is this?


#3

The camera target is set to “campfire” with no duration and limited boundaries. I don’t do CoffeeScript, but this isn’t how other levels do it from what I’ve seen.


#4

Commander Craig returns, awesome!
Someone used my level as inspiration.


Back to professional:
Except the already mentioned camera-bug I also dislike that everything just explodes. In one second your archers randomly attack a yak and in the next second dozens of yaks, enemies, projectiles, archers ect. fly all over the place. Maybe give the enemy a slightly reduced vision-range so they won’t immediately attack, or lock them with a referee in place. You could also include some vision-blocking walls for example.
I had a look in the editor and it seems that you intend the player to sacrifice a soldier to pass the mines. Maybe implement a narrow path, otherwise the pirates have no chance to get to their own treasure.


#5

Hello Everyone,

Camera Bug- I’m not sure what happened with the level but it should be fixed now. If not, then we might need @nick to help us!

Crazy Archers- I made a path out of fence walls so that is primarily fixed… :smile:

Solider Sacrifice- Yes, I did intend for you to sacrifice one solider, @J_F_B_M.

Just a tip- Defeat all the enemies that you can take down, (e.g Ogre Scouts, Fangriders). For all the tough enemies, (e.g Witch, Captain), you can use Commander Craig and the Archer Queen to take them down.

Hope this helps!

Endercore79


#6

Crazy Archers: It still doesn’t work. The archers can apparently see through walls and they attack the nearest sand yak.

On another note, your level gives Incomplete too soon. Once you kill all ogres, you have two and a half seconds to blow up the fire traps and loot all the treasure. Don’t you think it’s a little short?


#7

Hi,

@ChronistGilver I have set all archers to start as peaceful so they won’t attack any yaks for now. This is a temporary solution. Until this gets solved, just bear with me. :smile:. Also, once you kill all the ogres, you now have 60 seconds to sacrifice the paladin, blow up the mines, and grab the treasure :wink:.

Hope this helps!

Endercore79


#8

Wait, it has to be the paladin? What if the paladin dies?


#9

Also, your patch hasn’t taken effect yet. It still ends on Incomplete after two and a half seconds and the archers still attack the sand yaks.

It also says that one fire-trap is a dud. How can you tell which one it is?


#10

The good old way. Who ever gets the short end has to trial-and-error.


I guess you had, but just to be sure: Are you on http://direct.codecombat.com/play/level/cavendous-canyon ?


EDIT I just checked it out, archers are still bugging out, game still ends too soon and devour on Nalfar is way too much fun. Barely survived with 19 HP though.


#12

Fixed world-ends (it now ends when you collect the gems, unimportant if you killed all ogres)
Fixed archers shooting yaks (they will still do so on sight, but they cannot see them anymore)


#13

I can’t get to the Chest of Gems. The Bloodhenge keeps blocking my way.


#14

Collision for Bloodhenge turned off. This is probably only an intermediate solution, time for Endercore to come up with something for that.


#15

I finished the level in less than half the maximum time and am sure Tharin collected all treasure; however, the level refuses to admit that I finished looting the pirates. I had enough health to blow Tharin sky-high without killing him, so I didn’t sacrifice a minion. Could this be the problem?


#16

I have the exact same issue as stated by @GundericusTheMighty.

In addition, it is also possible to avoid exploding a single mine and extraction the diamond by using jumping/leaping granted by the best boot.

Level is not finishing despite collecting all diamonds. Have a look at this screen shot. Notice that treasure is taken but mines still intact:

Cheers


#17

Have you sacrificed the sacrifice as is demanded by one of the goals?


#18

Even if they did, what would happen if the sacrifice, by chance, stepped on the dud instead of the real fire traps?


#19

By sacrificing either a soldier or an ordinary archer (not Archer Queen), still not completing ‘loot the pirates’:

The screen shot was of sacrificing a soldier. Same result with sacrificing an ordinary archer.


#20

You are supposed to sacrifice the paladin whose name is “Sacrifice”. Do that, then come back if you still have problems.


#21

Sacrificing “Sacrifice” (the only paladin) is still not working (Using Google Chrome on Windows).

My Code
self.command(self.findByType("paladin")[0], "move", {"x":28,"y":51})
def enemiestokill():
    enemies = self.findEnemies()
    ToKill = []
    for enemy in enemies:
        if enemy.type != "sand-yak":
            ToKill.append(enemy)
    return self.findNearest(ToKill)

loop:
    enemy = enemiestokill()
    if enemy:
        while enemy.health >= 0:
            self.attack(enemy)
    else:
        break

self.command(self.findByType("paladin")[0], "move", {"x":138,"y":75})
self.moveXY(77, 75)
self.moveXY(103, 58)
self.wait(25)
self.moveXY(132, 69)
self.moveXY(146, 79)
self.moveXY(51, 46)