Next level indicator in Sarven desert incorrect, pointing to non-free


#1

It seems that the progress arrow (for the next main track level to play) a couple of levels into Sarven desert is incorrect, as it’s pointing to a paid level:


I’d have expected the arrow to keep indicating the next level on the main “free” route. Am I mistaken or is this a bug?


#2

The arrow is trying to help you complete all of that area not which way to complete it. It is incorrect if you are trying to get to mountain. It also will go to a payed level to get you to subscribe.


#3

If you are a subscribe, the arrow will always point to the level earliest you have not completed. For example, if you are on the last level in desert but didn’t complete a subscriber level, it will point to the subscriber level because you didn’t complete it.


#4

I am not subscribed and have been used to it/interpreting it as pointing me to the next mandatory level to complete. It therefore was slightly surprising and for a short while slightly perplexing that it was pointing me to a subscriber only level. For a short while I thought that meant I would not be able to continue without subscribing, until I noticed that it was in fact not pointing to a challenge on the main path, and I therefore tried manually opening the next free level myself. (And the next few after that.) The behaviour seemed (to me, being still quite new) inconsistent at this point given how it behaved prior to me reaching this point in the game, hence why I made the report. But if you say this is expected then that’s fine, I suppose! :slight_smile:


#5

OK, but in the previous areas the arrows only pointed to those levels I had to do to progress towards the end of the area, not every incomplete level as such, that is to say it proceeded with all free/open levels on the main path to the exit, and did not divert/point to or “get stuck on” (like here) on non main-route/paid/members only levels. So in this respect the behaviour at the above point seems at odds with the behaviour in earlier areas. My experience of this (as new user) at this point was thus some slight surprise, which is why I’m reporting it, as I’d have thought you might want to correct it. But if you insist this is correct then I rest my case. :slight_smile:


#6

I noticed this as well, it’s strange behaviour. Up until now it has only ever pointed to free levels. I tried some trickery to get through anyway and the next level it points to is Sand Mushrooms, which is even weirder as it requires a pet that is restricted for that level?

Edit: Apologies, I didn’t realise it said 2017 on the posts not 2018 xD


#7

It’s XD, not xD (20)