Problem running the code combat dev environment


#1

Not sure where to post this, so hopefully this is correct.

So in an effort to try and track down the bugs I’ve come across I decided to try my hand at running the dev environment. I think I am very close but for some reason I’m not seeing anything come up when I go the final http://localhost:3000 page. The page loads, but its just the basic page (with the default infrastructure) without any specific content so the page is effectively empty. As part of the installation I did the mongodb snapshot restore thinking that might be the issue, but still no luck.

I’ve installed the system on Ubuntu 12.04 LTS and have tried both Firefox v26 and Chrome 31.0.1650.63–same problem on both.

I did the installation manually (I followed the “do-it-yourself way”) and wrote up my own installation guide for Ubuntu 12.04 (which I can post if that would be helpful), so there is likely something I missed vs. the “new, easy, buggy way”. I looked through the install scripts with that latter method and was afraid I might bork my Ubuntu environment hence the do-it-yourself approach (I’m a bit averse to running anything as root that hasn’t been pretty well tested).

There are no errors emitted from bin/coco-mongodb or bin/coco-dev-server. The only error I am seeing is during the start up of bin/coco-brunch (which appear largely harmless):

$ bin/coco-brunch 
/bin/sh: 1: ulimit: error setting limit (Operation not permitted)
04 Jan 13:13:06 - warn: `-c, --config` option is deprecated. Use `--env` and `config.overrides` instead

The only part I really had to hack on to get to work was the bower.json file located in the root of the tree so that bin/coco-brunch wouldn’t complain. I had to copy it into several locations in the bower_components directory until I stopped getting errors. The rest of the system came up pretty cleanly. Perhaps that’s the problem?


#2

Hi SirArt–sounds like a thorny mess! Let’s get this resolved for you and anyone else that would run into the same issues. Why don’t you jump in our HipChat room and we can debug this more quickly over there? https://www.hipchat.com/g3plnOKqa


#3

I’ve go to around the same point getting it running in cygwin on windows. Tried to get the setup scripts to a point they could setup most stuff, however still have problems with UAC escalation on the node.msi - might be easier to make that a manual step for windows. Made a bunch of other changes in those scripts to get most of the other stuff working though. Can see about writing up a guide later.

I’ve currently got all 3 parts running, but when loading localhost:3000 I get a blank white screen. Some HTML is getting loaded, however the div page-container is completely empty.


#4

@nerago, I’d love to see the cygwin-based install instructions! We’re working on the Windows side of the setup scripts today, so hopefully we can get everything running smoothly.

It sounds like there might be some JavaScript error–if you check the Chrome JS console, does anything show up?

Will be in that HipChat room all day if you want to jump in and get this sorted out.


#5

I’m having trouble getting this set up as well. I created a VM on my windows 7 machine and installed the CoCo Appliance. Things seem to be working, but when I try to create a new level to edit. I get stuck on this page:

It just sits there as if it is trying to load, but failing to actually do so. Any help for me? I’d love to jump in hipchat with someone that could help, but I’m in Singapore, so my time doesn’t exactly match normal US time. My typical time working on this would be around 8-10pm here = 4-6am Pacific. I also might work a bit around 10 am = 6 pm. Who might be a good person to help me out? And what would be a time that would work?

I tried playing one of the levels and got


#6

You might need the database restore stuff. @schmatz how does this work in the VM?