Play Home Contribute GitHub Join Us Discourse Staff Members GitHub Contribution Guides Team

Solved: Storming the Tower of Error - infinite loop{SOLVED}


#1

I’m having an issue with this level. When I place the fire trap on the X, the game hangs. I’m not sure if my computer is too slow to handle the complexity of the level, but this error comes up afterward. It’s even created a memory error in Chrome and has told me to close Chrome.

Is there something I’m doing incorrectly here? Or is there a reason why this particular level is creating this infinite loop error?


#2

Nothing’s wrong with your code.
I’ve seen comments before which say to switch your browser to another one, they mainly suggest Fire Fox.
I hope this helps.
:lion: :lion: :lion:


#3

I’ll give that a go-ahead. Thank you.


#4

Gave it a go in Firefox. Initially it ‘worked’, as in not hanging after the initial fire trap placement. Scout was taken out, troops moved out of the camp, and I could see the locations of the red X’s. However, on subsequent code runs, it hangs at exactly the same spot: during or immediately after the placement of the first fire trap.

Maybe I do need a faster computer. Perhaps that is the solution here. It seems strange that 1 level would cause such an issue. Could there be a memory leak in the level coding? It is a user-created level.


#5

I’m not sure now,
maybe @stephanie can help.
:lion: :lion: :lion:


#6

@Rytrik are you still having this issue? Can you PM me your username? That way I can take a look. Thanks!


#7

It’s not obvious what to do in this level. See the storming-the-towers-of-areth video:
The level run on lubuntu linux on 2GB memory stick with 4GB RAM


#8

Hi Stephanie. I pm’d you.

I got it to work now. I was slightly off on a few values. Fixed them, and it works now. Level completed. Thank you everyone.