When Playing, Zoom Is Crazy


#1

It almost is impossible to see when playing! I have to change my zoom to 50%, in order to see, but even then its hard. Any1 know how to fix it, or have had this problem? I’m on internet explorer.


#2

Anyone had this problem? I’ve been waiting for a response for a couple of days.


#3

I’m not sure if I’m running into the same issues as you are, but I do wish there was some documentation of what the various zoom levels are supposed to mean. I think zoom level 1 is supposed to show the entire level and the other zoom levels are probably some sort of constant multiple of the max level, but I don’t remember seeing any actual documentation of that.


#4

@thewaffledimens Hmm, I’m not sure what you mean by a crazy zoom. Could you show a screenshot of what you’re seeing? Do you mean the zoom of the play area, or for the whole page? What version of internet explorer are you using? You might want to make sure it’s the latest, 11, or try Chrome or Firefox.

@gosnat It sounds like you’re talking about the level editor and setting zooms there within scripts. I recommend using the modal for selecting areas for where to point the camera or where to limit user visibility. Is that what you’re asking about?


#5

Well, I had been using surface - camera - zoom and target to get the visible area I wanted. I just tried using surface - Camera - Boundary and then giving the bottom left and top right corners of the area I wanted to show. I ended up with a visible area that was much less than what I asked for. Is that what you meant?


#6

Level editor zoom level 1 just corresponds to 10 pixels per meter, which is fairly zoomed out (the default level is 2).

The camera boundary selector won’t take into account aspect ratio, so you’ll only be able to see a viewport that fits inside the bounds on the smallest dimension (width or height).


#7

I am also having issues with crazy zoom, there are many times even if I zoom all the way out I can only see small portions of the level, also many time when I submit a level it sets a zoomed in level and I cant zoom out or see what is happening.