Play Home Contribute Github Join Us! Discourse Staff Members Github Contribution Guides Team

[Adventurer] Mined Gems

#1

Another circle-point level by @Bryukh. This is a mastery-style level, so be sure to check out the previous levels: Clumsy Circle Demo, Safe Spot Usage

And now onto the main course: Mined Gems

Post any comments here.

1 Like
#2

Hmmm, apparently there is a chest of gems at position (-7,42). My infinite glasses are picking it up and running to it since it is definitely outside the circle.

Once I accounted for that, code worked fine.

Nice chain of levels @Bruykh!

#3

Hm, It should be limited. Maybe it’s a problem with the first frame :frowning:

As the loading tip said :wink:

#4

Updated and fixed. Thanks! I mistyped and that was a reason.

#5

imho
secret is too hard and not obvious
I am awaiting something like teleportation to the new map at entrances

#6

Yep, that’s why they are secrets. Of course it’s not too hard to find them if you know how.

#7

Speed ring issue: if an outer gem is close to some wall or tree, the hero bounces, and on his way back to the center he walks onto an exploding gem…

Mined Gems - Speed Ring
#8

Could you give more information? I’m not sure that is a “speed ring” issue because positions of gems are speed-independent. Also, if you use “move-to-gem -> move-to-centre” then inertia doesn’t affect.

#9

I can’t reproduce the error, but the issue was with the inertia: when the hero reached the gem, he bounced off of a nearby tree, and didn’t go back the same way --> kaboom!

#10

@Bryukh I have the same problem as ant .

#11

first it starts out like this:

image

then,

image

look closey to the two gems beside the gem that senick is going to get!

image

and…

image

safely collected!

image

image

!!! :confused: ??

#12

Is that the mimic pet?

#13

mimic pet is not good on this level LOL ROFL
yay i got regular

#14

really?
:grimacing: I did not think of that!

#15

I have the same problem w/the hero “bouncing off” the trees w/the speed ring. I’m using Tharin,& I added having the hero say “getting” before moving toward the gems & “centering” before returning to the center. Tharin gets the 1st gem, which is directly above the center for me, & returns w/o problem, but after he gets the 2nd gem, which is along the top left treeline, & says “centering,” he suddenly moves 7-8m along the treeline(down & to the right for me), before returning to the center, walking through a gem that blows up. When I unequip the speed ring & run the exact same code, the level is successfully completed. I’m using boots of jumping & the moveXY() function, but the same result happened w/a homemade moveXY using move().

#16

Never mind about the speed ring, I had the same issue w/o it. I think the problem is that gems above & to the left of the hero are too close to the trees, so the hero “bounces” away from the trees. The gems just generated in different places the 1st time I ran the level w/o the ring than when I ran it w/the ring.

#17

I resubmitted my code that passed and ran into the same issue when I had a gem in the top left corner along the tree line. My code is basic, moveXY to gem position and move XY back to center. The seed with the gem in this position seems to create a problem. If you submit again and get a better seed, you will probably pass. Just to clarify, I wasn’t using the speed ring, only Pender who is a faster hero. I switched heroes several times and found that Okar (the slowest) can pass this seed, but no others can (that I tried).

bouncing%20treeline
not%20bouncing%20treeline

This does look like an issue that could be investigated more for this particular gem placement on this seed. @Chaboi_3000 What are your thoughts?

#18

Mined Gems - Speed Ring

#19

I tested and found out that all heroes with a speed of 6+ will fail with the unlucky seed. Setting the speed to 6 in the referee solved it. I submitted a patch to fix this. Thanks for reporting.