Play Home Contribute Github Join Us! Discourse Staff Members Github Contribution Guides Team

Cannot Place Thangs in Editor

Whether it’s a terrain or thang, I cannot place any thangs in the editor. Even after reloading, or logging out/in, it still returns the same error.
Console error:

Uncaught TypeError: Cannot read property 'isFullyLoaded' of undefined
    at n.onRandomTerrainGenerated (editor-6860d4d24847ab48ad82.bundle.js:1)
    at Object.publish (app.js:349)
    at n.onGenerate (editor-6860d4d24847ab48ad82.bundle.js:1)
    at HTMLDivElement.i (app.js:53)
    at HTMLDivElement.dispatch (app.js:44)
    at HTMLDivElement.m.handle (app.js:44)

Can anyone else repro this bug? For me, I can consistently repro this issue, but it might be a problem with my account.

@Andrew @stephanie, any ideas of why this may be happening?

Update: This only applies to Generate Terrain now.

I’m seeing the same error, but only on two terrains. The Grassy terrains don’t seem to display properly after I select them and it doesn’t bring me back to the main editor either. The floor shows up in the “Current Thangs” list, but I can’t interact or see them. I’m able to select all of the other terrains, but some are not showing in the preview. Thanks.

@brooksy125, a temporary fix to this issue is to fork other levels and use that terrain.