Error loading from server (Sessions) Not found. (Linux Ubuntu)


#1

Greetings,

I have everything installed on my linux ubuntu and when I load http://localhost:3000/hoc?go=true I get the error message about Sessions!

Loading…
Error loading from server (Sessions) Not found.

I was able to login and set a login for myself. I can click skip, then select javaScript as a language, then go to courses, and I run into it again.

CoursesView
http://localhost:3000/courses
Loading…Error loading from server (Sessions) Not found.

Cheers!


#2

I believe this is a known issue, see here.


#3

Thanks, but not sure that’s the same issue as mine. I’m on a fresh install and wanting to just navigate into the javascript or python existing courses on a fresh install to test the very first level/gameplay. That seems to be others that have gotten further than me and are wanting to add new courses / languages?


#4

Oh… wait, I think i see what you are saying. “Those models aren’t included in the database dump”. so the git clone doesnt have any courses at all to work with? Not even the first level that’s available to unpaid accounts?


#5

I guess so.
Although the game engine is free and open source, the level contents have rights reserved. Hence, only a few levels are available in the public DB dump for development and testing purposes. My interpretation of the linked issue is that the public dump does not contain any course and there is no easy way to create one. I’ll verify whether this is the case when I’m home. :slightly_smiling:


#6

Thanks! I cant seem to get to any levels to explore to workings of the system. Seems only the shell of the site as it were. Where does one access the few levels available in the public DB dump? I tried under courses, under play, under create class, cant seem to find a way too actually “play” anything on. That’s what I was really interested in looking into was the whole gameplay mechanics of it and creating levels and seeing how they were constructed, etc.

Thanks for the help!


#7

That is a good point—that is likely a side-effect of a recent change that now redirects /play to the courses version if you have never played the campaign version before (which is the case when you make a fresh install). Perhaps someone can confirm this (cc @nick).

For now, you can open http://localhost:3000/play/dungeon directly. The first two levels should be playable. Summit’s Gate is also playable (in the /mountain area). I don’t recall whether there are more campaign levels in the public dump but you can find them in the levels collection in MongoDB.


#8

sweetness, thanks! That did the trick and I can see some levels. Pretty awesome to see all the gets and posts running live in terminal :smiley:

Thanks for all the help, blown away by how it’s all working on coffeescript and a mondodb mostly…

cheers,

Logan


#9

If you sync your fork, the code which defaults you to playing courses instead of campaign shouldn’t be active (that was just during early December for Hour of Code). Could that have been why it was redirecting you?