Game Development 1 Level 1 bug?


#1

So I’m stuck on the first level for Game Dev 1, I feel like the answer is right in front of my face but it won’t let me game.spawnXY(“fence”, anywhere);


so either the Game Dev Level 1 has a bug or I’m an idiot, it’s probably the latter…


#2

For some reason you are in Lua.

Did you mean to be using JavaScript?


#3

yes i tried to switch to JavaScript but it only applied to the Dungeon Level, which was a bit weird.


#4

Please email us at team@codecombat.com and we will try to see what happened. Let us know you posted in the forums so we can assign your email accordingly!


#5

Can you not do the Game Development stages with LUA? if not how can I change the language?


#6

it should be the “change hero” button:

In the game level itself click on “Game Menu” -> “Change Hero” and choose Python

In the campaign view that shows all of the game development levels, click on the hero icon at the bottom:
“Hero Icon” -> “Python Language” -> “Save”

One of these should allow the level to load with Python.


#7

I tried changing it to JavaScript but it’s stuck on Lua, so I don’t know if it would let me change it to Python…


#8

I have tried to change it in-game but when I click on change hero it takes me to the campaign menu.
Do I need to do the level in LUA or something?


#9

if you change lang you all ways need to hit the restart up in the corner (it wipes out all code and resets to the code you are in)

or you could stay in Lua and change the // to – witch is Lua’s comment out


#10

If you play a normal level from the Dungeon or Forest campaign and choose Python as your language, then immediately exit the level and go to the game development it may accept your settings from the level before.

So in this case we would be trying to leverage another level to change the settings.